Wednesday, 23 April 2014 19:57

beggarly

500 - JHtmlBehavior::mootools not found.

Report Xmap bugs on this forum.

500 - JHtmlBehavior::mootools not found.

Postby svanschu » Tue Oct 23, 2012 10:56 am

Joomla 3.0 HTML sitemap results in 500 - JHtmlBehavior::mootools not found.

JHtmlBehavior::mootools does not exist anymore. You need to use JHtmlBehavior::framework or something like this ...
User avatar
svanschu
Fresh Boarder
Fresh Boarder
 
Posts: 3
Joined: Thu Jul 12, 2012 9:12 am
Location: Germany

Re: 500 - JHtmlBehavior::mootools not found.

Postby guilleva » Fri Dec 28, 2012 11:54 am

Hi, thanks for letting me know about the issue, I will fix it an release and updated versions soon. I the meantime, you can still see the HTML if you are not logged in as an super administrator or if you are not logged in.


If you want to fix the problem, open the file components/com_xmap/views/html/tmpl/default.php and replace the line:

JHTML::_('behavior.mootools');

with

JHTML::_('behavior.framework');

Thanks
User avatar
guilleva
Administrator
Administrator
 
Posts: 1527
Joined: Wed Sep 12, 2007 3:10 am
Location: San José, Costa Rica

Re: 500 - JHtmlBehavior::mootools not found.

Postby svanschu » Fri Dec 28, 2012 3:00 pm

Thx, I know ;)

Using it since long time and done some addons to the old xmap and the new one and will do more. Really great extensions :)
User avatar
svanschu
Fresh Boarder
Fresh Boarder
 
Posts: 3
Joined: Thu Jul 12, 2012 9:12 am
Location: Germany

Re: 500 - JHtmlBehavior::mootools not found.

Postby guilleva » Fri Dec 28, 2012 3:16 pm

Great!! Thanks! ;)
User avatar
guilleva
Administrator
Administrator
 
Posts: 1527
Joined: Wed Sep 12, 2007 3:10 am
Location: San José, Costa Rica

Re: 500 - JHtmlBehavior::mootools not found.

Postby manzanofab » Wed Mar 20, 2013 6:57 am

Hi
I did the modifications, but i got the following error
Fatal error: Call to undefined method JUtility::getToken() in C:\wamp\www\Joomla3\components\com_xmap\views\html\tmpl\default.php on line 20
thanks
manzanofab
Fresh Boarder
Fresh Boarder
 
Posts: 2
Joined: Wed Mar 20, 2013 6:55 am

Re: 500 - JHtmlBehavior::mootools not found.

Postby manzanofab » Wed Mar 20, 2013 10:13 am

Hi
I was checking some other forums and i found that replacing line 20 into this
$ajaxurl = "{$live_site}index.php?option=com_xmap&format=json&task=ajax.editElement&action=toggleElement";

will fix the problem
I left line 17 as JHTML::_('behavior.mootools');
in case some one is having the same issue
manzanofab
Fresh Boarder
Fresh Boarder
 
Posts: 2
Joined: Wed Mar 20, 2013 6:55 am

Re: 500 - JHtmlBehavior::mootools not found.

Postby mhehm » Wed Mar 27, 2013 4:12 am

test beta version:
http://joomla.vargas.co.cr/en/forum?task=viewtopic&f=2&t=4463&sid=9f89d54af0d599ceeb13ee1393d45209
User avatar
mhehm
Senior Boarder
Senior Boarder
 
Posts: 71
Joined: Sun Jan 20, 2013 1:22 pm
Location: Iran

Re: 500 - JHtmlBehavior::mootools not found.

Postby a3z211 » Sun Mar 31, 2013 10:23 am

manzanofab wrote:Hi
I was checking some other forums and i found that replacing line 20 into this
$ajaxurl = "{$live_site}index.php?option=com_xmap&format=json&task=ajax.editElement&action=toggleElement";

will fix the problem
I left line 17 as JHTML::_('behavior.mootools');
in case some one is having the same issue


Thank you very much!! I was desperate because I couldn't fix the problem! Now it's working all right
a3z211
Fresh Boarder
Fresh Boarder
 
Posts: 1
Joined: Sun Mar 31, 2013 10:21 am


Return to Bugs



Who is online

Users browsing this forum: Bing [Bot] and 1 guest