Saturday, 30 August 2014 08:28
beggarly

some missing translations (1 hardcoded, some in german)

Report Xmap bugs on this forum.

some missing translations (1 hardcoded, some in german)

Postby Grinsekatze » Sat Feb 07, 2009 11:51 pm

Hi there,
first of all I want to thank you for that great component!!

But as often there are also some bugs so I decided to register here and let you know:

1. There is still one hardcoded text string. It's within /administrator/components/com_xmap/admin.xmap.html.php (line 207):
There is still the word "Options" within a span-tag. I changed it to "<?php echo _XMAP_EDIT_MENU; ?>" so now I have the language specific word for Options.
2. Within /administrator/components/com_xmap/language/german.php:
Not all strings are translated into german. So the two new strings corresponding to version 1.2 are still in english. Here are the correct german lines:
Code: Select all
   define('_XMAP_COMPRESSION','Kompression');
   define('_XMAP_USE_COMPRESSION','Komprimieren Sie die XML-Sitemap, um Bandbreite zu sparen');

Also there are two missing &szling; to display the german ß correct when you use ISO-8859-1 coded files. In general it would be better to switch to UTF-8 so you don't need to code special chars to ascii and as Joomla has also switched to UTF-8 since version 1.5 it would be easier.

Greetings
Grinsekatze
Grinsekatze
Fresh Boarder
Fresh Boarder
 
Posts: 1
Joined: Sat Feb 07, 2009 11:34 pm

Re: some missing translations (1 hardcoded, some in german)

Postby guilleva » Sun Feb 15, 2009 4:20 pm

Hi Grinsekatze, thanks for your post. I have fixed this in the svn version with your tips.

It'll be available in the next version.

Regards,

Guillermo Vargas
User avatar
guilleva
Administrator
Administrator
 
Posts: 1527
Joined: Wed Sep 12, 2007 3:10 am
Location: San José, Costa Rica


Return to Bugs



Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest

cron