Sunday, 21 September 2014 16:10
beggarly

Sitemap displays blank white page

Report Xmap bugs on this forum.

Sitemap displays blank white page

Postby MetalTome » Tue Jul 28, 2009 5:08 am

Hello,

First I'll say Xmap is the best Sitemap component out there. The only problem I'm facing now is that I have over 24,000 links in my site map and it no longer will display. It tries to load it for awhile then just spits out a blank white page in the web browser. Here is the URL to my Site Map:

http://www.metaltome.com/home/site-map

I realize I could exclude menu items to have less links, yet this sort of defeats the purpose of the site map, as I want all my content spidered by search engines (Google). I don't see any settings to split the HTML sitemap into multiple pages (which would probably solve this issue).

Do you know of a way to fix this issue? Many thanks!
MetalTome
Fresh Boarder
Fresh Boarder
 
Posts: 2
Joined: Tue Jul 28, 2009 5:01 am

Re: Sitemap displays blank white page

Postby MetalTome » Thu Jul 30, 2009 3:29 am

Anyone? Bueller? Bueller?
MetalTome
Fresh Boarder
Fresh Boarder
 
Posts: 2
Joined: Tue Jul 28, 2009 5:01 am

Re: Sitemap displays blank white page

Postby DigitalMediaGuy » Tue Sep 08, 2009 11:09 pm

I also have a very large site and get the dreaded blank white page when trying to load my xmap sitemap from the Joomla front end... On top of this, Google is now rejecting my sitemap because it is too large!

Can anyone help me to solve this issue?

PS. I have tried to limit my Content Plugin "Max Articles" to 1000 to see if I could get it to load as well with no success...

Ideally I would like to split my sitemap into several different sitemaps and have everything included?

Please... Anyone !
DigitalMediaGuy
Fresh Boarder
Fresh Boarder
 
Posts: 7
Joined: Tue Sep 08, 2009 11:00 pm

Re: Sitemap displays blank white page

Postby guilleva » Wed Sep 09, 2009 12:29 am

Hi, you can create multiple sitemaps and include diferent menus on each sitemap, or exclude some menu items on one sitemap and exclude the rest from the other.
User avatar
guilleva
Administrator
Administrator
 
Posts: 1527
Joined: Wed Sep 12, 2007 3:10 am
Location: San José, Costa Rica

Re: Sitemap displays blank white page

Postby DigitalMediaGuy » Wed Sep 09, 2009 1:42 am

Thank you... I will try it later on and let you know how it goes!

:mrgreen:
DigitalMediaGuy
Fresh Boarder
Fresh Boarder
 
Posts: 7
Joined: Tue Sep 08, 2009 11:00 pm

Re: Sitemap displays blank white page

Postby DigitalMediaGuy » Wed Sep 09, 2009 10:51 pm

Ok... So I have two sitemaps now!

One is for things like articles, news, blogs, etc

The other is for my forums, community, resources, etc!

So... here is my problem:

When I went into the preferences to add the menu ID's to be excluded in my sitemap... I accessed the drop-down and it includes WAY more than just my actual mainmenu ID's... For example: When I go to the menu manager in joomla and look at the auctual menu id's they are all 6 digit numbers like "100300, 100304, 100307, 100200"

However, In the Dropdown menu in the back of XMAP I get a bunch more ID's from all over my site! From various components, etc.... with random digit numbers like this, "100131, 100110, 46, 82, 81, 148"

So... I went through anyways and manually excluded all the forums, community, resources, etc from my 1st sitemap (which was a lot of clicks, but ok)

But now I am stuck at my 2nd sitemap! Because of the huge drop-down menu I would have to go through and manually click and exclude hundreds if not thousands of menu id's are included in my 1st sitemap (it is way more stuff to exclude... too many really)

If I could get the drop-down to just show my actual menu id's then I wouldn't have to exclude hundreds or thousands of items manually!

On top of this....

There are also a few sections of duplicate items showing up in my 1st (published) sitemap on the front end...

If anyone can provide some more information I would GREATLY appreciate it
DigitalMediaGuy
Fresh Boarder
Fresh Boarder
 
Posts: 7
Joined: Tue Sep 08, 2009 11:00 pm


Return to Bugs



Who is online

Users browsing this forum: No registered users and 3 guests