Saturday, 01 November 2014 06:09
beggarly

2.0 RC1 ... archived articles NOT showing

Report Xmap bugs on this forum.

Re: 2.0 RC1 ... archived articles NOT showing

Postby guilleva » Sun Aug 07, 2011 10:31 pm

Hi, please try attached upgrade for Xmap's content extension which should also support archived content. Just install it as any other Joomla's extension. no need to uninstall the current extension.

Regards,

Guillermo
Attachments
xmap-com_content-2.0.1.zip
Xmap content extension for Joomla 1.6 and 1.7
(8.66 KiB) Downloaded 287 times
User avatar
guilleva
Administrator
Administrator
 
Posts: 1527
Joined: Wed Sep 12, 2007 3:10 am
Location: San José, Costa Rica

Re: 2.0 RC1 ... archived articles NOT showing

Postby alforreca » Sun Aug 07, 2011 10:58 pm

Thanks Guillermo,

But unfortunately is does not seem to work... it is only showing me the published articles, not the archived :(

I was trying to see if there is any option to activate this in the sitemap or inside the content plugin but can't see anything... is there anything I need to activate?
alforreca
Fresh Boarder
Fresh Boarder
 
Posts: 16
Joined: Sat Jul 02, 2011 8:50 am

Re: 2.0 RC1 ... archived articles NOT showing

Postby guilleva » Mon Aug 08, 2011 4:12 am

Do you have any menu item "Archived Articles" menu item included in your sitemap?
User avatar
guilleva
Administrator
Administrator
 
Posts: 1527
Joined: Wed Sep 12, 2007 3:10 am
Location: San José, Costa Rica

Re: 2.0 RC1 ... archived articles NOT showing

Postby alforreca » Mon Aug 08, 2011 7:59 am

No, I have no Menu item "Archived articles" displaying inside the sitemap.

The archived articles are inside my blog.... and the blog is inside the main menu... and that one is selected. But there is nothing saying archived articles, or any added new menus?!?!?!
alforreca
Fresh Boarder
Fresh Boarder
 
Posts: 16
Joined: Sat Jul 02, 2011 8:50 am

Re: 2.0 RC1 ... archived articles NOT showing

Postby guilleva » Mon Aug 08, 2011 11:43 pm

The way Xmap works is expanding the menu items. It reads each menu item and then includes all the content that is associated to that menu item. If there is no menu item pointing to Joomla's archived articles then Xmap won't include them. I don't know what you mean with your blog, but Xmap doesn't parses the content of the pages looking for links, it's just all about the menu items.
User avatar
guilleva
Administrator
Administrator
 
Posts: 1527
Joined: Wed Sep 12, 2007 3:10 am
Location: San José, Costa Rica

Re: 2.0 RC1 ... archived articles NOT showing

Postby alforreca » Mon Aug 08, 2011 11:59 pm

Let me start by saying:
Thanks for your help, patience and work to solve this.

I mean... the archived articles are in the same menu as the blog. But not showing up.

The blog is inside am article category, the category as published articles and archived articles.
There is a menu that points to the blog "category", therefore the published articles are showing up, but the archived ones are not.

So what could be wrong here?!

***EDITED***
In content plugin I have:
Expand Categories: Always
Also tried in xml sitemap only... did not work either.
alforreca
Fresh Boarder
Fresh Boarder
 
Posts: 16
Joined: Sat Jul 02, 2011 8:50 am

Re: 2.0 RC1 ... archived articles NOT showing

Postby alforreca » Tue Aug 09, 2011 12:12 am

Let me know if you want to have a quick look at it.
I can give you a remote desktop connection with teamviewer.
Just google teamviewer and download it... it's free, and a great app for remote desktops, everybody is using it.
alforreca
Fresh Boarder
Fresh Boarder
 
Posts: 16
Joined: Sat Jul 02, 2011 8:50 am

Re: 2.0 RC1 ... archived articles NOT showing

Postby ben80 » Thu Aug 11, 2011 4:47 pm

Hi,

Sorry to hijack this post, but I've had similar problems. I also installed the downloadable patch which didnt let me display archived articles. Luckily I had a work around as I had an "archive" category, so I just re-published them under this. However if a new release of the fix comes out I'd love to know.

On a related topic and excuse this question if this newbie doesnt understand Joomla. I had (and would like) all my articles published through the "Articles - Newsflash" module on my home page. As this is not directly related to the Menu I couldnt get any articles to display on Xmap. So then I created a "Category Blog" Home Menu and all articles magically appeared. However now my site doesnt look half as slick. So essentially is there any way I can link the menu to an articles module?

Thanks,

Ben
ben80
Fresh Boarder
Fresh Boarder
 
Posts: 3
Joined: Fri Jul 15, 2011 5:15 pm

Re: 2.0 RC1 ... archived articles NOT showing

Postby alforreca » Thu Aug 11, 2011 5:09 pm

Hello Guillermo,

Seems there's more people with is issue... feel better now knowing this is not related to my system.
I also installed the downloadable patch which didnt let me display archived articles. Luckily I had a work around as I had an "archive" category, so I just re-published them under this. However if a new release of the fix comes out I'd love to know.


The problem with your solution is google SEO... by creating another category and or menu, the link will change from when they were publish to now that they are archived... You will have a huge list of web crawl / html errors in google webmaster.

So I really can not move my "tons" of archived articles from the current category or menu.
alforreca
Fresh Boarder
Fresh Boarder
 
Posts: 16
Joined: Sat Jul 02, 2011 8:50 am

Re: 2.0 RC1 ... archived articles NOT showing

Postby ben80 » Sat Aug 13, 2011 11:58 am

Sadly thats a very good point! Although you are definitely not alone with this problem. I await news on the solution...

Does anyone have any information on my second point about the modules, or is this functionality that Xmap doesnt cater for and never will?
ben80
Fresh Boarder
Fresh Boarder
 
Posts: 3
Joined: Fri Jul 15, 2011 5:15 pm

PreviousNext

Return to Bugs



Who is online

Users browsing this forum: No registered users and 1 guest