Thursday, 30 October 2014 13:43
beggarly

Xmap 2.0 - Error when accessing to site map at the front end

Report Xmap bugs on this forum.

Xmap 2.0 - Error when accessing to site map at the front end

Postby ventluc » Sun Jul 31, 2011 10:49 pm

Hello,
I use Joomla 1.6.6 and I installed xmap 2.0 for Joomla 1.6/1.7. I defined a new sitemap in "Sitemaps manager" of xmap 2.0 component called "My Site MAP". Then:

a) I created a new Joomla menu called "JM" at the front end of type "Xmap->Html Site map";
b) I create a new entry in JM called "Site Map" that appears in the front end of my web site and I linked it to "My Site MAP".

When I access to "My Site MAP" link at the front end of my web site I receive the following error:

Warning: mysqli::query(): Empty query in <joomla installation folder>/libraries/koowa/database/adapter/abstract.php on line 509 Fatal error: Cannot access protected property JException::$code in <joomla installation folder>/plugins/system/koowa.php on line 194 Fatal error: Exception thrown without a stack frame in Unknown on line 0 Warning: Unknown: Failed to write session data (user). Please verify that the current setting of session.save_path is correct () in Unknown on line 0

What does it mean? Can someone help me? :)

Thanks a lot in advance!!

Luca
ventluc
Fresh Boarder
Fresh Boarder
 
Posts: 5
Joined: Sun Jul 31, 2011 10:39 pm

Re: Xmap 2.0 - Error when accessing to site map at the front end

Postby guilleva » Mon Aug 01, 2011 6:45 am

Hi, It looks like the problem is not with xmap but with that koowa plugin, maybe you can try contacting it's developers about that error.
User avatar
guilleva
Administrator
Administrator
 
Posts: 1527
Joined: Wed Sep 12, 2007 3:10 am
Location: San José, Costa Rica

Re: Xmap 2.0 - Error when accessing to site map at the front end

Postby ventluc » Mon Aug 01, 2011 5:58 pm

Koowa plug-in? Which Joomla module does it refer to? What is it useful for? I didn't installed it!!! Is it integrated in Joomla? Thanks a lot in advance. Luca
ventluc
Fresh Boarder
Fresh Boarder
 
Posts: 5
Joined: Sun Jul 31, 2011 10:39 pm

Re: Xmap 2.0 - Error when accessing to site map at the front end

Postby ventluc » Sun Aug 07, 2011 2:49 pm

I found the problem!! Koowa plugin is installed by Kunena module (Forum) and it is not possibile to disable it (this operation can crash the system! You can check this issue in many forum over the Internet...) ...so I tried to disable "Xmap - Kunena Plugin" of Xmap and now alla works!!! (Obviously Kunena section is not included in the site map). I tried to install Joomla 1.7 and Kunena 1.6.5 but the problem still exists. :| So I pray Xmap programmers to verify Xmap integration with Kunena and to solve this issue so that I can integrate in the site map Kunena section! :) Thanks a lot in advance!! ;)
ventluc
Fresh Boarder
Fresh Boarder
 
Posts: 5
Joined: Sun Jul 31, 2011 10:39 pm

Re: Xmap 2.0 - Error when accessing to site map at the front end

Postby guilleva » Tue Aug 09, 2011 1:07 am

Umm, When I install Kunena in my dev environment I don't get the "koowa" library installed anywhere on the filesystem. :s Do you know how did you get it in that path? Did you install any special plugin/extension, other than the component it self?
User avatar
guilleva
Administrator
Administrator
 
Posts: 1527
Joined: Wed Sep 12, 2007 3:10 am
Location: San José, Costa Rica

Re: Xmap 2.0 - Error when accessing to site map at the front end

Postby ventluc » Tue Aug 09, 2011 6:02 am

I think Xmap uses Koowa plugin's libraries to connect Kunena...in fact as I said if I disable Kunena plugin of Xmap all works well !!! But I don't know if Koowa plugin has been installed by Xmap or not....Any idea? :(
ventluc
Fresh Boarder
Fresh Boarder
 
Posts: 5
Joined: Sun Jul 31, 2011 10:39 pm


Return to Bugs



Who is online

Users browsing this forum: No registered users and 2 guests