Saturday, 30 August 2014 12:29
beggarly

Joomla 1.7 xmap 2- sitemap not complete

Report Xmap bugs on this forum.

Joomla 1.7 xmap 2- sitemap not complete

Postby immi1971 » Thu Aug 25, 2011 6:21 pm

Hi there,

today I've installed xmap on my joomla 1.7 installation. After that I found out that the sitemap isn't complete. :o

Image
Image

Does anyone have any ideas?

Thanks,
Immi
immi1971
Fresh Boarder
Fresh Boarder
 
Posts: 2
Joined: Thu Aug 25, 2011 6:14 pm

Joomla 1.7 xmap 2- sitemap not complete

Postby dezi168 » Tue Aug 30, 2011 9:11 pm

I have the same problem !
I run Joomla 1.7 and xmap2.0.

On an other website (www.sukuk.fr), it works fine ! (J1.7 and xmap2.0).

I can not understand what happens.
The only difference is that for www.sukuk.fr, I started the dev withJ1.6 with xmap2.0RC1 and with the site I have a problem I started the dev with J1.7 and installed xmap 2.0 directly.

Any idea will be welcomed.

Dezi
dezi168
Fresh Boarder
Fresh Boarder
 
Posts: 2
Joined: Tue Aug 30, 2011 8:58 pm

Re: Joomla 1.7 xmap 2- sitemap not complete

Postby immi1971 » Fri Sep 02, 2011 9:23 am

no idea? :(
immi1971
Fresh Boarder
Fresh Boarder
 
Posts: 2
Joined: Thu Aug 25, 2011 6:14 pm

Re: Joomla 1.7 xmap 2- sitemap not complete

Postby dezi168 » Wed Sep 14, 2011 6:05 pm

I think I have an idea :
I thought that the sitemap would be the list of menu items.
But if you have two or more menu-items which are linked to a same article. Only the first menu-item would be listed in the sitemap.

I am still developping my website, so there is a lot of menu-items created by linked to the same "empty article". These menu items are not listed. That would be an explanation why the sitemap is not complete.

Does anyone can confirm this assomption ?
dezi168
Fresh Boarder
Fresh Boarder
 
Posts: 2
Joined: Tue Aug 30, 2011 8:58 pm

Re: Joomla 1.7 xmap 2- sitemap not complete

Postby iglew » Thu Sep 15, 2011 9:32 am

We're tesing Joomla 1.7 on a bare new install with Xmap 2 can confirm that where 2 differently named menus with same content only first appears.

However is this a bug? Surely this prevents submission of duplicate content to search engines and thus incurring a duplicate penalty?
iglew
Fresh Boarder
Fresh Boarder
 
Posts: 4
Joined: Thu Sep 15, 2011 9:27 am

Re: Joomla 1.7 xmap 2- sitemap not complete

Postby tarkin » Fri Sep 16, 2011 1:01 am

Same problem on our 1.7 site.

Indeed, it seems the occurrence of menu aliases messes it all up.

I have situations where a menu item has sub-menu items (esp. category lists), but because a menu alias occurs elsewhere in the menu for the parent menu item...none of the sub items get indexed.

Consequently, am missing a significant number of links in the XML version of the sitemap. However, HTML version has them all.

Grateful for any fixes as I can't find a single other working sitemap component for 1.7.
tarkin
Fresh Boarder
Fresh Boarder
 
Posts: 2
Joined: Fri Sep 16, 2011 12:59 am

Re: Joomla 1.7 xmap 2- sitemap not complete

Postby wadesigns » Thu Sep 29, 2011 9:05 am

Hi There

I run site map on my 1.7 site and get this msg;

Fatal error: Call to undefined method JLanguage::getBackwardLang() in /home/alterego/public_html/administrator/components/com_xmap/admin.xmap.php on line 25

It states : Error building Admin Menus - can someone tell me what I am missing please?

KR

Debs
wadesigns
Fresh Boarder
Fresh Boarder
 
Posts: 1
Joined: Thu Sep 29, 2011 9:04 am


Return to Bugs



Who is online

Users browsing this forum: No registered users and 1 guest