Friday, 25 July 2014 22:18
beggarly

2 bugs?: not showing menus and multilingual

Report Xmap bugs on this forum.

2 bugs?: not showing menus and multilingual

Postby szuijderwijk » Wed May 02, 2012 2:35 pm

Hi all,

Last week I migrated my site from Joomla 1.5 to Joomla 2.5.4. I have always used Xmap for creating my sitemaps, but on this new version (xmap 2.2.1) I cannot get 2 things to work:
- not all (sub)menu's and articles are showing in the xml sitemap. The html sitemap works great, but the xml stops generating sitemap links after the first submenu.
- My site has 2 languages: dutch and english. Dutch is the site's language, and English the second language. I can access the Dutch xml sitemap, but I cannot access the English sitemap (both from the back end link and trying to enter the url with /en/ or &lang=en). Again, the HTML sitemap works great.

My site is: www.skuzet.nl. The HTML sitemaps can be accessed through the site. The xml sitemaps are:
- Dutch: http://www.skuzet.nl/index.php?option=com_xmap&view=xml&tmpl=component&id=1
- English: http://www.skuzet.nl/index.php?option=com_xmap&view=xml&tmpl=component&id=2

Does anyone has the solution for the above problems?

Regards,

Stefan
szuijderwijk
Fresh Boarder
Fresh Boarder
 
Posts: 3
Joined: Thu Jun 24, 2010 10:17 am

Re: 2 bugs?: not showing menus and multilingual

Postby websitebron.nl » Sun May 06, 2012 8:00 am

I have exactly the same problems, my site behaves identical.
The Dutch XML map is OK, if I add &lang=en I get an error:

Fout tijdens laden van stijlblad: Er is een netwerkfout opgetreden tijdens het laden van een XSLT-stijlblad:http://www.websitebron.nl/index.php?option=com_xmap&view=xml&layout=xsl&tmpl=component&id=1&filter_showtitle=&lang=en


I tried all the other options too, as described here:
http://joomla.vargas.co.cr/en/documentation/34-xmap-2/how-to/108-xmap-sitemap-as-sitemapxml

But nothing works!

Eric
websitebron.nl
Fresh Boarder
Fresh Boarder
 
Posts: 6
Joined: Sun May 06, 2012 7:55 am

Re: 2 bugs?: not showing menus and multilingual

Postby websitebron.nl » Wed May 09, 2012 6:49 pm

bump
websitebron.nl
Fresh Boarder
Fresh Boarder
 
Posts: 6
Joined: Sun May 06, 2012 7:55 am


Return to Bugs



Who is online

Users browsing this forum: No registered users and 2 guests