Saturday, 20 December 2014 15:48
beggarly

Menu-item type featured articles showing from both languages

Report Xmap bugs on this forum.

Menu-item type featured articles showing from both languages

Postby bongobongo » Fri Oct 11, 2013 6:40 pm

Hi

I have a menuitem of menuitem type featured articles.

In the Xmap I see that articles from both norwegian and english languages are listed below the menuitem related to norwegian and english.

In other words.... all the featured articles (both english and norwegian articles) are listed in Xmap below this menuitem.

Has this been a known bug (I'm still using the version I installed for Joomla 1.6)?
Can I just install the latest version of Xmap (for 2.5), I'm using Joomla 2.5.14, on top of what is allready installed -- without loosing anything --- and will this fix this issue?
bongobongo
Fresh Boarder
Fresh Boarder
 
Posts: 15
Joined: Fri Jan 07, 2011 1:43 pm

Re: Menu-item type featured articles showing from both langu

Postby bongobongo » Fri Oct 11, 2013 10:06 pm

Hi again

I think I'm using 2.0 version of Xmap.

I just found where the bug was in that version (do not have time at the moment to check the newest - if the bug is there at all)... Here is how I fixed it:

In the file:
administrator/components/com_xmap/extensions/com_content/com_content.php

then in the function: includeCategoryContent($xmap, $parent, $catid, &$params,$Itemid)
replace:
Code: Select all
$where = 'a.featured=1';


with:
Code: Select all
$lang = JFactory::getLanguage();
$langTag = $lang->getTag();
$where = "a.featured=1 and language='$langTag'";


If this bug-fix is not implemented in the new version, and this cool extension is still maintained, it would be nice to see an upgraded version.
If not, then it should be easy now to fix for everyone by themselves...
bongobongo
Fresh Boarder
Fresh Boarder
 
Posts: 15
Joined: Fri Jan 07, 2011 1:43 pm

Re: Menu-item type featured articles showing from both langu

Postby bongobongo » Sat Oct 12, 2013 6:02 pm

Just looked at the source code for Xmap 2.3.3 (for Joomla 2.5 and above).
It looks like the language is handled better in that version, and without having tested it
I'm quite sure that version 2.3.3 should work without the bugfix in my previous post here.
bongobongo
Fresh Boarder
Fresh Boarder
 
Posts: 15
Joined: Fri Jan 07, 2011 1:43 pm


Return to Bugs



Who is online

Users browsing this forum: No registered users and 2 guests