Monday, 24 November 2014 21:42
beggarly

missing items in xml sitemap but shown in html sitemap

An open forum for opinions and general questions

missing items in xml sitemap but shown in html sitemap

Postby Brujo » Tue Dec 04, 2012 6:09 pm

Hi together,
XMAP 2.3.2 - Joomla 2.5.8

I created a new Menu " Xmap" with 3 Items of the type "Url" and createt a new sitemap and checked the Mneu "Xmap"

Menu Xmap
Item A -> Menu Item Type External URL (internal link to phoca fotogalerie categorie 1)
Item B -> Menu Item Type External URL (internal link to phoca fotogalerie categorie 2)
Item C -> Menu Item Type External URL (internal link to phoca fotogalerie categorie 3)

when i open the html sitemap I see all 3 Items (and link works as expected) but when I open the xml view of this sitemap there are 0 items.

what do I miss here? any hint would be great.

Brujo
Brujo
Fresh Boarder
Fresh Boarder
 
Posts: 8
Joined: Sun Sep 12, 2010 3:47 pm

Re: missing items in xml sitemap but shown in html sitemap

Postby zymurgy42 » Sat Jan 19, 2013 2:49 am

I have the same issue. I am using a hidden menu, one menu has 40+ pages under it. They show in the HTML view, but not in the XML.

xmap.PNG
xmap.PNG (6.57 KiB) Viewed 5753 times


You will see from above that the HTML version shows 110 items, yet XML only shows 42. Where are the other 68 items?

Gordon.
zymurgy42
Fresh Boarder
Fresh Boarder
 
Posts: 2
Joined: Wed Nov 07, 2012 5:21 am

Re: missing items in xml sitemap but shown in html sitemap

Postby moose999 » Fri Feb 08, 2013 2:24 pm

I have the same issue, many more items in my HTML sitemap than my XML sitemap.

Joomla 2.5.9
XMAP 2.3.2
Xmap - Virtuemart Plugin 2.0.1
Virtuemart 2.0.18a

TIA,
Moose.
Attachments
sitemap_error.jpg
moose999
Fresh Boarder
Fresh Boarder
 
Posts: 1
Joined: Fri Feb 08, 2013 2:20 pm

Re: missing items in xml sitemap but shown in html sitemap

Postby Aleksander » Fri Feb 15, 2013 3:30 am

Guys,

This seems to be my history for the last months and now can see I am not alone. I am having more variables that could be affecting and not sure where else to isolate:

XMAP 2.3.2
Joomla 2.5.8
K2 2.6.3
Xmap - K2 Plugin 1.2

This is a bilingual site using K2. The html maps are awesome but all the attempts to create the xml maps in the secondary language fail

I tried all the fixes for the K2 plugin and also find a fix for the language but fixed and not an issue anymore in this XMAP version

130214-xmaps-issue.jpg


As you can see I created 3 different sitemaps:

one global for all the menus in all languages, the second in English and a third one in Spanish

Any idea that can help us?
Aleksander
Fresh Boarder
Fresh Boarder
 
Posts: 3
Joined: Sun Feb 03, 2013 5:12 pm

Re: missing items in xml sitemap but shown in html sitemap

Postby Aleksander » Wed Feb 20, 2013 3:53 am

Hi there,

I found something today after opening the xml map in:
http://site.xxx/index.php?option=com_xmap&view=xml&tmpl=component&id=2
Logged in and being redirected to http://site.xxx/en/xml/2-leon-times-en-espanol?view=xml and noticed that the base language was in English
Changed to http://site.xxx/es/xml/2-leon-times-en-espanol?view=xml

and guess what? is listing the xml sitemap, not sure why is this but I have by now this workaround.


Any light about what could be happening?

Hope this can help everyone with the same issue
Aleksander
Fresh Boarder
Fresh Boarder
 
Posts: 3
Joined: Sun Feb 03, 2013 5:12 pm

Re: missing items in xml sitemap but shown in html sitemap

Postby AlexHK » Sat Mar 16, 2013 3:25 am

I too had a difference between HTML and XML. I went to Extensions, disabled the Content Plugin, visited the XML page and voila more items showed up. Enabling the Content Plugin seems not to have them removed them again.

Something you can try.

Joomla 2.5.9
Xmap 2.3.3 beta
AlexHK
Fresh Boarder
Fresh Boarder
 
Posts: 5
Joined: Tue Mar 12, 2013 11:20 am


Return to General



Who is online

Users browsing this forum: Exabot [Bot], Google Adsense [Bot], Yahoo [Bot] and 3 guests