Saturday, 25 October 2014 07:06
beggarly

XML Parsing Error: not well-formed

An open forum for opinions and general questions

XML Parsing Error: not well-formed

Postby SuPeR-MaN » Thu May 29, 2008 6:40 am

Hi all,

first of all I have to say that in my opinion Xmap is the best component for sitemap generation for Joomla and I would like to use this but I have a problem.

I got this message:
XML Parsing Error: not well-formed
Location: http://########
Line Number 1, Column 1:
^


This problem happen when "Search Engine Friendly URL:" of Joomla is YES.
If I disable SEF URL the sitemap works fine.

I use sh404SEF for SEF URL generation.

Could you help me?

Thank you

P.S. If I look at page source I see sitemap links, but on front page I always see "XML Parsing Error: not well-formed"
SuPeR-MaN
Fresh Boarder
Fresh Boarder
 
Posts: 2
Joined: Thu May 29, 2008 5:47 am

[Solved] XML Parsing Error: not well-formed

Postby SuPeR-MaN » Thu May 29, 2008 4:54 pm

I solved my problem.

In sh404SEF settings I set in
Advanced Configuration > By Component
"Do Not Modify" for XMAP component.

...and now works fine...and I have my sitemap B) :lol:

Bye
SuPeR-MaN
Fresh Boarder
Fresh Boarder
 
Posts: 2
Joined: Thu May 29, 2008 5:47 am

Re:[Solved] XML Parsing Error: not well-formed

Postby marxam » Thu May 29, 2008 8:01 pm

@ SuPeR-MaN:

Your settings didn't work for me for some weird reason. I have around 11000 links in my mosets tree and the sitemap file is not being generated correctly.

My error is as follows in Firefox:

XML Parsing Error: no element found
Location: http://www.xxxxxxxxxxxx.co.uk/index.php?option=com_xmap&sitemap=3&view=xml&no_html=1
Line Number 1170, Column 1:

Wonder if someone could help?
marxam
Fresh Boarder
Fresh Boarder
 
Posts: 7
Joined: Thu May 29, 2008 5:13 pm

Re:XML Parsing Error: not well-formed

Postby marxam » Mon Jun 02, 2008 4:58 pm

After several unsuccessful attempts, I swapped opensef for Sh404 and did advanced configuration as some other users suggested but result still is the same.

In the Mosets Tree Plugin for xmap settings, the sitemap is successfully generated if links [there are around 11000 links in my db] are skipped.

Enabling indexing only for the Mosets Tree categories generates a neat sitemap with around 560 links.

However, when the Mosets Tree Links indexing option is also enabled, it gives errors, with or without sef urls.

Firefox displays the following error:

XML Parsing Error: no element found
Location: http://www.xxxxxxxxxxxx.co.uk/index.php?option=com_xmap&sitemap=3&view=xml&no_html=1
Line Number 3225, Column 1:

Line number varies each time. The rest of the page looks blank but when page source is viewed, all the links up to the error line are there.

Please help!
marxam
Fresh Boarder
Fresh Boarder
 
Posts: 7
Joined: Thu May 29, 2008 5:13 pm


Return to General



Who is online

Users browsing this forum: Exabot [Bot], Google [Bot] and 3 guests