Friday, 18 April 2014 05:42
beggarly

XML XMAP No Longer Working

An open forum for opinions and general questions

XML XMAP No Longer Working

Postby matt » Wed Oct 29, 2008 2:12 pm

My HTML XMAP works fine:

http://magicgizmo.com/home/index.php?op ... &sitemap=1

But not the XML one (it says 0 URLs):

http://magicgizmo.com/home/index.php?op ... &no_html=1

It used to work fine, now Google says:

Unsupported file format
Your Sitemap does not appear to be in a supported format. Please ensure it meets our Sitemap guidelines and resubmit. Help Help

Joomla 1.5.7
SEF URLS On
XMAP 1.2
matt
Fresh Boarder
Fresh Boarder
 
Posts: 6
Joined: Wed Oct 29, 2008 2:08 pm

Re: XML XMAP No Longer Working

Postby guilleva » Thu Oct 30, 2008 2:09 pm

Hi, please try cleaning your cache, and if you have the feature to compress the sitemap, please try disabling it!
User avatar
guilleva
Administrator
Administrator
 
Posts: 1527
Joined: Wed Sep 12, 2007 3:10 am
Location: San José, Costa Rica

Re: XML XMAP No Longer Working

Postby matt » Thu Oct 30, 2008 2:29 pm

I tried clearing the cache and compression was already disabled. Still same problem.
matt
Fresh Boarder
Fresh Boarder
 
Posts: 6
Joined: Wed Oct 29, 2008 2:08 pm

Re: XML XMAP No Longer Working

Postby guilleva » Thu Oct 30, 2008 2:43 pm

Honestly... I have not idea what is wrong! :(

Please double check your settings to see if you find something there, Also, please check your PHP error log to see if you find something related to xmap on it!
User avatar
guilleva
Administrator
Administrator
 
Posts: 1527
Joined: Wed Sep 12, 2007 3:10 am
Location: San José, Costa Rica

Re: XML XMAP No Longer Working

Postby matt » Thu Oct 30, 2008 3:26 pm

Ok, dumb question, where would I find the PHP logs?

I also tried unintsalling the XMAP, deleting the tables, and reinstalling and still get the same problem.
matt
Fresh Boarder
Fresh Boarder
 
Posts: 6
Joined: Wed Oct 29, 2008 2:08 pm

Re: XML XMAP No Longer Working

Postby guilleva » Thu Oct 30, 2008 5:01 pm

Hi, the location of the log file depend of your hosting service. You could find where is it located in your php ini settings. You can find that in your site:

Help-> System Info and then select the tab: "PHP Information"

look for the setting "error_log", it will tell you where the php error log file is, also, check if the value for "log_errors" is "On"
User avatar
guilleva
Administrator
Administrator
 
Posts: 1527
Joined: Wed Sep 12, 2007 3:10 am
Location: San José, Costa Rica

Re: XML XMAP No Longer Working

Postby matt » Thu Oct 30, 2008 7:19 pm

I found the error log and no XMAP errors in it.

This all stopped working when I was doing a bunch of changes to the site: upgrading to Joomla 1.5.7 adding new components etc.
matt
Fresh Boarder
Fresh Boarder
 
Posts: 6
Joined: Wed Oct 29, 2008 2:08 pm

Re: XML XMAP No Longer Working

Postby matt » Fri Oct 31, 2008 2:53 am

Ok, I reinstalled XMAP and the plugins and all is working now. Not sure why exactly is wasn't working before, but all well. thanks!
matt
Fresh Boarder
Fresh Boarder
 
Posts: 6
Joined: Wed Oct 29, 2008 2:08 pm

Re: XML XMAP No Longer Working

Postby guilleva » Fri Oct 31, 2008 2:09 pm

Great! Thanks for let me know that!
User avatar
guilleva
Administrator
Administrator
 
Posts: 1527
Joined: Wed Sep 12, 2007 3:10 am
Location: San José, Costa Rica


Return to General



Who is online

Users browsing this forum: Bing [Bot] and 2 guests

cron