Tuesday, 02 September 2014 23:53
beggarly

Missed lang string cause Chinese character mess?

An open forum for opinions and general questions

Missed lang string cause Chinese character mess?

Postby baijianpeng » Wed Nov 21, 2007 3:53 am

In the file ajaxResponse.php, at line 13, the code is

[code:e669a80b]header ('Content-Type: text/xhtml; charset='. _XMAP_CHARSET);
[/code:e669a80b]

I think the _XMAP_CHARSET may be a language string. But it was not in the language file.

So, when the dropdown menu list contains Chinese menu items, then those Chinese characters will be displayed as unreadable symbols.

IF _XMAP_CHARSET belongs to language file, please add it.

Thanks.
JoomlaGate - Chinese Joomla! Users\' Portal

http://www.joomlagate.com
User avatar
baijianpeng
Junior Boarder
Junior Boarder
 
Posts: 27
Joined: Thu Nov 08, 2007 2:24 pm

Re:Missed lang string cause Chinese character mess?

Postby guilleva » Wed Nov 21, 2007 5:24 pm

Hi,

_XMAP_CHARSET should be the charset encoding for the language, it should be defined on the language file with something like
[code:27ebfdcc]
define('_XMAP_CHARSET', 'utf-8');
[/code:27ebfdcc]

For chinese, which charset is used normally?
User avatar
guilleva
Administrator
Administrator
 
Posts: 1527
Joined: Wed Sep 12, 2007 3:10 am
Location: San José, Costa Rica

Re:Missed lang string cause Chinese character mess?

Postby baijianpeng » Wed Nov 21, 2007 10:25 pm

We always use utf-8 encoding for Chinese version of Joomla!.

sorry, I just found out that _XMAP_CHARSET was already included in the english.php language file.

Please move this topic.

Thanks.
Last edited by baijianpeng on Thu Jan 01, 1970 12:00 am, edited 65535 times in total.
Reason: 1
User avatar
baijianpeng
Junior Boarder
Junior Boarder
 
Posts: 27
Joined: Thu Nov 08, 2007 2:24 pm


Return to General



Who is online

Users browsing this forum: Yahoo [Bot] and 2 guests