Wednesday, 23 July 2014 03:58
beggarly

Problem with showing "List All Categories" menus

An open forum for opinions and general questions

Problem with showing "List All Categories" menus

Postby gsadeghi » Thu Dec 22, 2011 8:07 pm

Hi,

first of all thank you for the great component, it is definitely a great help for all the webmasters.
Recently ive been having problem with xml sitemap showing a menu item which is set to show all the categories in a certain section. I will try to explain the problem in the simplest way possible.

I set up the xmap to select from the main menu. Menu item "Updates" set to show all the categories in section A (section A has sub-categories of 1, 2 , 3 and 4).
When I turned on the "Xmap - Content Plugin" the xml sitemap start showing ALL THE CATEGORIES under that menu item url. So instead of having only Update/A/1, Update/A/2 and so on, i get Update/B/1 Update/B/2 and all the categories which i have created in category management.
It seems like a bug but i might be mistaking. I should mention that i fixed the issue by creating another menu (hidden) and assign the main menu to it by menu item alias but i was wondering if there is a fix to avoid creating extra menus.

Thanks
gsadeghi
Fresh Boarder
Fresh Boarder
 
Posts: 1
Joined: Thu Dec 22, 2011 4:35 pm

Re: Problem with showing "List All Categories" menus

Postby jwxyz » Fri May 25, 2012 1:28 pm

Hi!

I seem to have the same problem, using Joomla 2.5.4 and Xmap 2.2.1 with the the Xmap - Content Plugin enabled. The site map lists all my content under the menu item of type "List All Categories", rather than just the content within the selected Top Level Category (as selected in the menu item). A bug perhaps?

Greetings,

jw
jwxyz
Fresh Boarder
Fresh Boarder
 
Posts: 1
Joined: Fri May 25, 2012 1:21 pm


Return to General



Who is online

Users browsing this forum: Bing [Bot] and 4 guests