Monday, 01 September 2014 23:28
beggarly

Xmap 2.2.1 and Joomla 1.7. Css not working!

An open forum for opinions and general questions

Xmap 2.2.1 and Joomla 1.7. Css not working!

Postby giampus » Fri Feb 17, 2012 3:24 pm

Hi

Im using Joomla 1.7.3 and now Xmap 2.2.1
Also! When i want to use my own css for xmap it doesn't work. Everytime xmap css is overwritten with the MAIN css of my joomla template. Even if I copy the xmap css into my template css it doesn't work.

So, please can anybody help me...thanks

Giampus
giampus
Fresh Boarder
Fresh Boarder
 
Posts: 1
Joined: Fri Feb 17, 2012 3:19 pm

Re: Xmap 2.2.1 and Joomla 1.7. Css not working!

Postby davex » Tue Mar 06, 2012 6:37 pm

Hi Glampus,

I had the same issue with Xmap 2.2.1. If you look at the source of the created xmap, you notice that the xmap is wrapped in a div id of xmap and the provided css shows a class. So I changed the css class as follows, just make sure your path to images is correct for your install.

/* New for site map, four level ul li levels site map March 06, 2012 */

#xmap ul li {
list-style-type:none;
margin: 0px;
padding-left: 18px;
font-weight: bold;
line-height: 16px;
background: url(../images/xmap/bullet.png) 0 -2px no-repeat;
} /* First 0 is left right and 2nd is top bottom */

#xmap ul li li {
background: url(../images/xmap/dia_red.png) 0 2px no-repeat; }

#xmap ul li li li {
background: url(../images/xmap/dia_teal.png) 0 2px no-repeat; }

#xmap ul li li li li {
background: url(../images/xmap/dia_teal.png) 0 2px no-repeat; }

/* end xmap css */

Hope this helps.
Davex
davex
Fresh Boarder
Fresh Boarder
 
Posts: 2
Joined: Tue Mar 06, 2012 6:29 pm


Return to General



Who is online

Users browsing this forum: Bing [Bot], Exabot [Bot], Google [Bot] and 3 guests

cron