Friday, 28 November 2014 12:19
beggarly

Gallery Description Dissapears

zOOm Media Gallery for Joomla 1.5

Gallery Description Dissapears

Postby ideamarket » Tue Apr 22, 2008 4:17 pm

Every time I write a new description in for a gallery it saves to the DB but when the page refreshes it shows up as blank. and now for some reason all the descriptions for the child galleries have been erased from the DB.

On line 282 it calls to load the content from the Database and it does not.

Best I can tell the error is in catsmgr.html.php line 282 and 283
Code: Select all
$content = (!empty($zoom->_gallery)) ? $zoom->_gallery->_descr : $zoom->_CONFIG['tempDescr'];


Code: Select all
editorArea( 'zOOmEditor1', $content, 'catdescr', '500', '200', '45', '5' );


zOOm - 1.5 release

Joomla - 1.5.0 stable
Last edited by ideamarket on Thu Jan 01, 1970 12:00 am, edited 65535 times in total.
Reason: 1
ideamarket
Fresh Boarder
Fresh Boarder
 
Posts: 15
Joined: Thu Mar 20, 2008 5:09 pm

Re:Gallery Description Dissapears

Postby ideamarket » Tue Apr 22, 2008 8:06 pm

Even if I echo $zoom->_gallery->_descr it still shows up blank I double checked the DB and the gallery I'm looking at does have a description.
ideamarket
Fresh Boarder
Fresh Boarder
 
Posts: 15
Joined: Thu Mar 20, 2008 5:09 pm

Re:Gallery Description Dissapears

Postby leonnoorman » Fri Jul 04, 2008 10:43 am

I experience the same problem in zoom 1.5 native. Is there a fix for this? However as long as I can see the description in the front end, I am fine.

What is worse is that description from images do not work; they disappear after saving and cannot be seen in the front end. I will open a separate topic for that.
leonnoorman
Fresh Boarder
Fresh Boarder
 
Posts: 15
Joined: Mon Jun 30, 2008 1:09 am

Re:Gallery Description Dissapears

Postby guilleva » Fri Jul 04, 2008 5:47 pm

Hi Lennoorman, I'm checking at this and I will be back with a solution soon.

Thanks for reporting this!
User avatar
guilleva
Administrator
Administrator
 
Posts: 1527
Joined: Wed Sep 12, 2007 3:10 am
Location: San José, Costa Rica

Re:Gallery Description Dissapears

Postby guilleva » Fri Jul 04, 2008 9:16 pm

Hi, here is the patch for the issue with the images description.
Please replace your file /component/com_zoom/www/admin/editimg.php with the one inside the attached zip file.
editimg.zip
(4.21 KiB) Downloaded 475 times


About the galleries description problem. I don't find the problem. It seems to be working fine. I can modify and save the description without problems.

If you want to show the description of the galleries in your frontend, the select yes for the option "Show album description within the gallery" in "Layout" tab of your ZMG settings.
Last edited by guilleva on Thu Jan 01, 1970 12:00 am, edited 65535 times in total.
Reason: 1
User avatar
guilleva
Administrator
Administrator
 
Posts: 1527
Joined: Wed Sep 12, 2007 3:10 am
Location: San José, Costa Rica

Re:Gallery Description Dissapears

Postby leonnoorman » Sat Jul 05, 2008 4:29 pm

Hi thx for the patch!
I installed it in the directory you described and replaced the old file. Then I went back in back end of Zoom and tried to add a description in the Media Manager, but I get the "your request is being processed..." error. Unfortunately that does not disappear. Pls see the attachment below.

About the galleries description problem: I still have this, even when I change the settings to show the description inside the gallery. I have added some screenprints in the file below. But for me that is not a high prio problem (since I found a workaround), I just wanted to show you what I experience. Perhaps these 2 problems are related somehow.

The Image description problem is a serious problem. Pls let me know when you have an idea how it can be solved.

Thx a lot for all your help!
Image_description_problem.zip
(219.85 KiB) Downloaded 455 times
Last edited by leonnoorman on Thu Jan 01, 1970 12:00 am, edited 65535 times in total.
Reason: 1
leonnoorman
Fresh Boarder
Fresh Boarder
 
Posts: 15
Joined: Mon Jun 30, 2008 1:09 am

Re:Gallery Description Dissapears

Postby guilleva » Sun Jul 06, 2008 1:42 am

Do you see any error message in your php error log?
User avatar
guilleva
Administrator
Administrator
 
Posts: 1527
Joined: Wed Sep 12, 2007 3:10 am
Location: San José, Costa Rica

Re:Gallery Description Dissapears

Postby leonnoorman » Tue Jul 08, 2008 6:17 am

Hi,
To be sure that the error was not caused by my setup, I first deleted Zoom again from my website. I also deleted all pictures and entries. Then installed again. I got the same error again with the old image setup, then installed your editimg.zip file and got same error as before.
I checked a error log file, but there was nothing in there. Perhaps I checked the wrong log file. Can you tell me where that error log file exactly is?

Thx for your help!
leonnoorman
Fresh Boarder
Fresh Boarder
 
Posts: 15
Joined: Mon Jun 30, 2008 1:09 am

Re:Gallery Description Dissapears

Postby guilleva » Tue Jul 08, 2008 1:02 pm

Hi, is there any way I can try to use your ZMG installation. It could be in the frontend. Please pm the info if you have no problem with that!

Thanks for your help and cooperation!
User avatar
guilleva
Administrator
Administrator
 
Posts: 1527
Joined: Wed Sep 12, 2007 3:10 am
Location: San José, Costa Rica

Re:Gallery Description Dissapears

Postby guilleva » Tue Jul 08, 2008 8:19 pm

Thanks for the info. Can you please install the patch I gave to you so I can test you ZMG with it!

Thanks!
User avatar
guilleva
Administrator
Administrator
 
Posts: 1527
Joined: Wed Sep 12, 2007 3:10 am
Location: San José, Costa Rica

Next

Return to zOOm



Who is online

Users browsing this forum: No registered users and 1 guest