Friday, 31 October 2014 05:39
beggarly

Installation error for Virtuemart Plugin

Report Xmap bugs on this forum.

Installation error for Virtuemart Plugin

Postby gchancy » Sun May 04, 2008 11:00 pm

Hello -


I have J1.5 running in legacy mode. I installed xmap 1.1 with no issue. However, when I use the installer to attempt to install the Virtuemart plugin, the following error occurs on a white screen of death:

Fatal error: Call to a member function on a non-object in /home/newho27/public_html/administrator/components/com_xmap/classes/XmapPluginInstaller.php on line 49


Any idea on how to get around this?
gchancy
Fresh Boarder
Fresh Boarder
 
Posts: 10
Joined: Tue Dec 18, 2007 4:02 am

Re:Installation error for Virtuemart Plugin

Postby guilleva » Thu May 15, 2008 6:26 pm

Hi, are you using PHP 4?

Can you try modifying your file: /administrator/components/com_xmap/includes/XmapAdmin.php and look for the line

$installer->setAdapter('xmap_ext',$xmapInstaller);

and change it to:

@$installer->setAdapter('xmap_ext',&$xmapInstaller);

Thanks
User avatar
guilleva
Administrator
Administrator
 
Posts: 1527
Joined: Wed Sep 12, 2007 3:10 am
Location: San José, Costa Rica

Re:Installation error for Virtuemart Plugin

Postby gchancy » Wed May 21, 2008 8:10 pm

Hello -

I put the fix in but no change. File renders same error. Can I manually unpack and load without using the installer?

Thanks,
Glen
gchancy
Fresh Boarder
Fresh Boarder
 
Posts: 10
Joined: Tue Dec 18, 2007 4:02 am

Re:Installation error for Virtuemart Plugin

Postby cifran1 » Thu Jun 05, 2008 10:23 am

Hi
I have the same problem...
I've installed Xmap 1.1 for Joomla 1.5 without problems
The installation of ALL plugins fails with the error:

Call to a member function on a non-object in /web/htdocs/www.cifranweb.it/home/web/administrator/components/com_xmap/classes/XmapPluginInstaller.php on line 49

regards
Claudio
cifran1
Fresh Boarder
Fresh Boarder
 
Posts: 6
Joined: Mon Jun 02, 2008 1:40 pm

Re:Installation error for Virtuemart Plugin

Postby guilleva » Thu Jun 05, 2008 4:53 pm

Hi, can you please provide me more info about your systems?

Which version of PHP/Web server are you using?

Thanks
User avatar
guilleva
Administrator
Administrator
 
Posts: 1527
Joined: Wed Sep 12, 2007 3:10 am
Location: San José, Costa Rica

Re:Installation error for Virtuemart Plugin

Postby guilleva » Wed Jun 11, 2008 3:38 pm

Hi, I know there is a problem with some PHP 4 installations. PHP 5 works fine. I'm trying to find a solution for PHP 4 users but I recommend you to upgrade to PHP 5 if you can.

Thanks
User avatar
guilleva
Administrator
Administrator
 
Posts: 1527
Joined: Wed Sep 12, 2007 3:10 am
Location: San José, Costa Rica

Re:Installation error for Virtuemart Plugin

Postby guilleva » Thu Jun 12, 2008 5:03 pm

Hi, can anyone try this and let me know if that fixed your problem?

Replace your /administrator/components/com_xmap/classes/XmapAdmin.php with the one on this zip file:
XmapAdmin.zip
(2.55 KiB) Downloaded 435 times
User avatar
guilleva
Administrator
Administrator
 
Posts: 1527
Joined: Wed Sep 12, 2007 3:10 am
Location: San José, Costa Rica

Re:Installation error for Virtuemart Plugin

Postby cifran1 » Sat Jun 14, 2008 11:56 am

guilleva wrote:Hi, can anyone try this and let me know if that fixed your problem?

Replace your /administrator/components/com_xmap/classes/XmapAdmin.php with the one on this zip file:
XmapAdmin.zip
(2.55 KiB) Downloaded 401 times


It works! Thank you wery much
Claudio
Last edited by cifran1 on Thu Jan 01, 1970 12:00 am, edited 65535 times in total.
Reason: 1
cifran1
Fresh Boarder
Fresh Boarder
 
Posts: 6
Joined: Mon Jun 02, 2008 1:40 pm


Return to Bugs



Who is online

Users browsing this forum: Google [Bot] and 3 guests

cron