Tuesday, 30 September 2014 16:03
beggarly

Gallery Manager Not Working

zOOm Media Gallery for Joomla 1.5

Gallery Manager Not Working

Postby dcsk » Tue Jul 08, 2008 5:48 am

I installed your Zoom for J!1.5 and noted some strange behavior of the component.

At the frontend when I use Gallery Manager through IE7, I got the waiting message forever and the left panel showing "loading". I noted that there is an IE error which said: Line 30, Char 988, Error: Object doesn't support this property or method, Code: 0, URL:...index.php?option=com_zoom&page=catsmgr&itemid=70.

If I open the same page user Firefox 3.0, there is no error, but the "save" button at the upper right corner is missing if I am using a administrator to login.

Please advise how to solve this problem.
User avatar
dcsk
Fresh Boarder
Fresh Boarder
 
Posts: 15
Joined: Tue Jul 08, 2008 1:56 am

Re:Gallery Manager Not Working

Postby admin » Tue Jul 08, 2008 4:46 pm

Hi, thanks for reporting that, I'm working on it right now. I'll be back with a solution for this soon.

Thanks
admin
Junior Boarder
Junior Boarder
 
Posts: 26
Joined: Mon Aug 27, 2007 7:32 pm

Re:Gallery Manager Not Working

Postby guilleva » Tue Jul 08, 2008 7:58 pm

Hi, I have found the problem. Please download the package again. You have two options:
1- Extract the file com_zoom/lib/js/button.js and upload it to your server into the path /components/com_zoom/lib/js/button.js or
2- Reinstall the component.

The second option will fix another problem reported by other user. (Specifically the file com_zoom/www/admin/editimg.php)
User avatar
guilleva
Administrator
Administrator
 
Posts: 1527
Joined: Wed Sep 12, 2007 3:10 am
Location: San José, Costa Rica

Re:Gallery Manager Not Working

Postby dcsk » Wed Jul 09, 2008 6:43 am

Thanks.

I upload the updated button.js and able to get rid of the waiting message. However, the left panel still connot display the tree properly. I got the following error message from IE7:

Line: 347, Char:9, documentElement is null or not an object, code: 0,

URL:...index.php?option=com_zoom&page=catsmgr&itemid=71.

No such error for FF3.

Hope you can fix this final bit!

Thanks again your effort to make this very best gallery component working under J!1.5
User avatar
dcsk
Fresh Boarder
Fresh Boarder
 
Posts: 15
Joined: Tue Jul 08, 2008 1:56 am

Re:Gallery Manager Not Working

Postby dcsk » Wed Jul 09, 2008 6:46 am

Still one more issue, the save button for Gallery Manager on the top right corner is still missing for user other than admin. Please advise how to fix.
User avatar
dcsk
Fresh Boarder
Fresh Boarder
 
Posts: 15
Joined: Tue Jul 08, 2008 1:56 am

Re:Gallery Manager Not Working

Postby guilleva » Wed Jul 09, 2008 9:38 pm

Hi, which template are you using for your site? Can I take a look at your frontend as a registered user?

Thanks!
User avatar
guilleva
Administrator
Administrator
 
Posts: 1527
Joined: Wed Sep 12, 2007 3:10 am
Location: San José, Costa Rica

Re:Gallery Manager Not Working

Postby dcsk » Thu Jul 10, 2008 1:06 am

Hi,

I sent you a PM for the login info.

Thanks
Last edited by dcsk on Thu Jan 01, 1970 12:00 am, edited 65535 times in total.
Reason: 1
User avatar
dcsk
Fresh Boarder
Fresh Boarder
 
Posts: 15
Joined: Tue Jul 08, 2008 1:56 am

Re:Gallery Manager Not Working

Postby guilleva » Thu Jul 10, 2008 7:07 pm

Hi, I have identified the problem and I have fixed this on the package. You can download it again and either: reinstall the ZMG or manually overwrite the files /components/com_zoom/zoom.php and /components/com_zoom/www/ajaxcallback.php with the ones in the package.

Please let me know if you have any questions.
User avatar
guilleva
Administrator
Administrator
 
Posts: 1527
Joined: Wed Sep 12, 2007 3:10 am
Location: San José, Costa Rica

Re:Gallery Manager Not Working

Postby dcsk » Fri Jul 11, 2008 10:23 am

Everythings works fine! Thanks very much.
User avatar
dcsk
Fresh Boarder
Fresh Boarder
 
Posts: 15
Joined: Tue Jul 08, 2008 1:56 am

Re:Gallery Manager Not Working

Postby withincontext » Wed Jul 16, 2008 10:28 pm

Hi, I've been using zOOm Media Gallery 2.5.1 RC4 for quite some time now on a Joomla 1.0 site. I have the same issue the user described above:

Back-end
- Missing Save button in all browsers
- Gallery tree not populating with existing galleries (quite a few of them)

I updated /components/com_zoom/lib/js/button.js and now I'm getting the JavaScript error in IE6: Object doesn't support this property or method (line: 30, char: 988).

I also updated /components/com_zoom/zoom.php and /components/com_zoom/www/ajaxcallback.php. Now I see the "Your request is being processed" layer but it never goes away. The Save button is still missing, as well.

What I don't understand is how to reinstall ZMG without losing all my galleries. Can you please provide a better explanation about how to do this?
withincontext
Fresh Boarder
Fresh Boarder
 
Posts: 1
Joined: Wed Jul 16, 2008 10:57 pm

Next

Return to zOOm



Who is online

Users browsing this forum: No registered users and 1 guest