Monday, 22 September 2014 18:13
beggarly

permissions problem

zOOm Media Gallery for Joomla 1.5

permissions problem

Postby dutchpainter » Wed Aug 27, 2008 10:14 pm

Hi, installation of native zoom went well. But i have a problem with the map permissions. The directories are created with chmod 511 so i cant do anything. It is not possible to upload images. Please help. :|
Last edited by dutchpainter on Thu Aug 28, 2008 11:31 am, edited 1 time in total.
dutchpainter
Fresh Boarder
Fresh Boarder
 
Posts: 5
Joined: Wed Aug 27, 2008 5:12 am

Re: permissions problem

Postby guilleva » Thu Aug 28, 2008 1:53 am

Hi, please try replacing the file /components/com_zoom/lib/JoomlaPlatform.php with the one in the attached zip file
Attachments
JoomlaPlatform.class.zip
(2.05 KiB) Downloaded 413 times
User avatar
guilleva
Administrator
Administrator
 
Posts: 1527
Joined: Wed Sep 12, 2007 3:10 am
Location: San José, Costa Rica

Re: permissions problem

Postby dutchpainter » Thu Aug 28, 2008 7:35 am

Hi,

it doesn't solve the problem. I know where the problems is but i cant fix it.
It is in the file JoomlaPlatform.class.php. If I change te code at line 159 to
Code: Select all
        //$perms = octdec($perms);
SO it doesnt doe anything anymore. My maps are chmodded correctly, to 777. Without the change they are chmodded to 511 which is octdec(777). What a coincidence... ;)
But with the change my configurationfiles (map etc) are chmodded wrong, to something like 376...?
So that change of code is not enough. Please help.
dutchpainter
Fresh Boarder
Fresh Boarder
 
Posts: 5
Joined: Wed Aug 27, 2008 5:12 am

Re: permissions problem

Postby dutchpainter » Thu Aug 28, 2008 9:47 am

I guess i found the bug. Some '''''''''' :D
I changed some code. putted them together in a patch.zip
Attachments
Patch2.zip
replace files
(44.15 KiB) Downloaded 503 times
dutchpainter
Fresh Boarder
Fresh Boarder
 
Posts: 5
Joined: Wed Aug 27, 2008 5:12 am

Re: permissions problem

Postby guilleva » Thu Aug 28, 2008 1:06 pm

Hi, thanks for your patch, can you tell me if you are using the "safe mode" in zoom (ftp feature)?
User avatar
guilleva
Administrator
Administrator
 
Posts: 1527
Joined: Wed Sep 12, 2007 3:10 am
Location: San José, Costa Rica

Re: permissions problem

Postby dutchpainter » Thu Aug 28, 2008 1:09 pm

No, i am not using the safemode in Zoom.
dutchpainter
Fresh Boarder
Fresh Boarder
 
Posts: 5
Joined: Wed Aug 27, 2008 5:12 am


Return to zOOm



Who is online

Users browsing this forum: No registered users and 0 guests