Tuesday, 30 September 2014 06:03
beggarly

Sitemap not indenting or expanding correctly

Report Xmap bugs on this forum.

Sitemap not indenting or expanding correctly

Postby Martle » Mon Dec 10, 2007 10:35 am

Hi

I would like to start by saying what a nice and effective component this is.

I installed Xmap a few days ago on my new site and although I have a sitemap it's just not displaying properly. Despite what I set in the config, it's neither indenting or expanding. It just shows as a long list of menu items, and content items.

You're welcome to take a look at http://www.martle.com and clicking on the 'Sitemap' in the menu.

I'm beginning to wonder if this is an issue with the template I'm using and if so, a simple fix would be most welcome.

Thanks.
Martle
Fresh Boarder
Fresh Boarder
 
Posts: 6
Joined: Mon Dec 10, 2007 10:15 am

Re:Sitemap not indenting or expanding correctly

Postby Martle » Tue Dec 11, 2007 3:56 pm

Partially solved this issue myself by reading down a few posts in which it was suggested to:

Go to your admin module for XMap and click on the little blue arrow in the top right hand corner. Choose preferences and change the CSS classname to sitemap.


Now my sitemap is indenting and expanding correctly. :laugh:

It's still not right though. My external links are still not visible and I was wondering if there is something else I should do to get it to work?

Amy ideas guys?

Before I go I'll just drop a few words to the poster above me who seems to be having the same problem. :dry:
Martle
Fresh Boarder
Fresh Boarder
 
Posts: 6
Joined: Mon Dec 10, 2007 10:15 am

Re:Sitemap not indenting or expanding correctly

Postby Martle » Wed Dec 12, 2007 6:45 pm

Has anyone any ideas as to why my external links are not showing on my sitemap? I've fiddled around with all the settings in the backend but nothing seems to show them up. I've got 5 external links on the 'links' tab on my main menu but non of them are visible in the corresponding folder on the sitemap.

I've tried every colour available and have ticked and unticked the boxes but all this is to no avail.

sitemap.jpg
sitemap.jpg (0 Bytes) Viewed 5106 times


Posted up a screenshot and my sitemap can be found here:http://martle.com/index.php?option=com_xmap&Itemid=41

I hope that somebody can help me with this as I'm beginning to tear my hair out. :dry:

Cheers
Last edited by Martle on Thu Jan 01, 1970 12:00 am, edited 65535 times in total.
Reason: 1
Martle
Fresh Boarder
Fresh Boarder
 
Posts: 6
Joined: Mon Dec 10, 2007 10:15 am

Re:Sitemap not indenting or expanding correctly

Postby guilleva » Wed Dec 12, 2007 8:30 pm

Hi Martle, sorry for the delay, the links item is not expanded because the is no plugin for that kind of item. I will make one but it would take some days.

Please post a plugin request for com_links in the Plugin forum, on this site.

Thanks.
User avatar
guilleva
Administrator
Administrator
 
Posts: 1527
Joined: Wed Sep 12, 2007 3:10 am
Location: San José, Costa Rica

Re:Sitemap not indenting or expanding correctly

Postby Martle » Wed Dec 12, 2007 10:57 pm

Thanks guilleva, I'll certainly post that request up.

Just a couple of things ...

I've just added a 'test' external link to one of my articles and that's not showing up as an external link on the sitemap either. I really do think that something isn't quite right with my installation.

I've also discovered that occasionally, my sitemap resorts to being a long list again with no indentation and can only be rectified by opening up Xmap within the backend. I don't change anything and when I return to the sitemap it then appears correctly again complete with indentations.:unsure:

I still think this is a fantastic component (If only I could get it to work!):)

Cheers
Martle
Fresh Boarder
Fresh Boarder
 
Posts: 6
Joined: Mon Dec 10, 2007 10:15 am

Re:Sitemap not indenting or expanding correctly

Postby guilleva » Sun Dec 16, 2007 6:28 pm

Hi, external links are link to other sites, if your link points to an article into the same site, then it is considered as a internal link.
User avatar
guilleva
Administrator
Administrator
 
Posts: 1527
Joined: Wed Sep 12, 2007 3:10 am
Location: San José, Costa Rica

Re:Sitemap not indenting or expanding correctly

Postby Sapient » Tue Feb 05, 2008 6:07 pm

Greetings,
I just installed this component and I am also having an issue with it not expanding the content section.

I changed the css name to sitemap with no change.

Was there a plugin created to fix this?

I was also wondering where the css is located for sitemap /v XMap

You can view the problem here:
http://www.hingedmind.com/genoa/component/option,com_xmap/Itemid,58/

Thanks for the component and support.

b
Sapient
Fresh Boarder
Fresh Boarder
 
Posts: 4
Joined: Tue Feb 05, 2008 5:59 pm

Solved - Sitemap not expanding correctly

Postby Sapient » Mon Feb 11, 2008 12:45 pm

I am not sure if this is related to others who are having a difficult time getting their content area to expand with the sitemap.

It is related to the height value...

In the template_css.css file there is a section of code that probably looks like this:

Code: Select all


.contentpaneopen {
   width            : 100%;
   text-align       : justify;
   padding-left     : 0px;
   padding-right    : 0px;
   height: 9px;
}



Should look something like:

Code: Select all
.contentpaneopen {
   width            : 100%;
   text-align       : justify;
   padding-left     : 0px;
   padding-right    : 0px;
   height: 100%;
}


Hope this helps...

Thanks,
-b
Sapient
Fresh Boarder
Fresh Boarder
 
Posts: 4
Joined: Tue Feb 05, 2008 5:59 pm

Re:Solved - Sitemap not expanding correctly

Postby guilleva » Thu Feb 14, 2008 3:05 am

Hi, thanks for your feedback.

It would be great if someone having the same issue could try this solution.
User avatar
guilleva
Administrator
Administrator
 
Posts: 1527
Joined: Wed Sep 12, 2007 3:10 am
Location: San José, Costa Rica


Return to Bugs



Who is online

Users browsing this forum: Bing [Bot] and 1 guest

cron