Friday, 01 August 2014 03:55
beggarly

XML Parsing Error

Report Xmap bugs on this forum.

XML Parsing Error

Postby adams.alex » Thu Feb 14, 2008 4:09 pm

Hi guilleva, no time no seen! I have one error in my sitemap and i do not see where is the problem. This is sitemap for one menu item, around 11000 items, and i clean the link for "&" and still does not work.
The link of sitemap is: http://www.time4music.biz/index.php?option=com_xmap&sitemap=5&view=xml&no_html=1

Asd the error is:
XML Parsing Error: no element found
Location: http://www.time4music.biz/component/option,com_xmap/sitemap,5/view,xml/no_html,1/
Line Number 4, Column 1:

Can you tell me what is wrong?
adams.alex
Junior Boarder
Junior Boarder
 
Posts: 23
Joined: Thu Sep 20, 2007 8:27 am

Re:XML Parsing Error

Postby Sapient » Thu Feb 14, 2008 4:42 pm

Greetings,
I would like to first apologize for attaching my problem to this post. Perhaps they are related. This error just started right after upgrading to Joomla 1.0.14. This is the only thing that has changed on the site. Though the error is different.

The site map is:

http://www.hingedmind.com/index.php/component/option,com_xmap/sitemap,1/view,xml/no_html,1/


The output is:

XML Parsing Error: junk after document element
Location: http://www.hingedmind.com/index.php/component/option,com_xmap/sitemap,1/view,xml/no_html,1/
Line Number 293, Column 1:

Of course google is choking...

Any ideas?


Thanks,
b
Sapient
Fresh Boarder
Fresh Boarder
 
Posts: 4
Joined: Tue Feb 05, 2008 5:59 pm

Re:XML Parsing Error

Postby guilleva » Thu Feb 14, 2008 10:40 pm

Sapient, I don't think your problem is related with the other one, your problem is with all your site and not with Xmap as you can see at the bottom of your homepage.

adams.alex, it looks like your site is getting a time out or memory problem, maybe you can try using Xmap 1.1 beta 1 released today and tell me how it works for you.
User avatar
guilleva
Administrator
Administrator
 
Posts: 1527
Joined: Wed Sep 12, 2007 3:10 am
Location: San José, Costa Rica

Re:XML Parsing Error

Postby Sapient » Thu Feb 14, 2008 11:03 pm

Thanks for the response guilleva,
I found the issue. With the upgrade of Joomla and the overwrite of some files, it changed the permissions on the shCache.php file.

I changed the permissions back and everything is working.

i.e. chmod of the below file fixed the issue (components/com_sef/shCache.php). To include the sitemap.


Warning: fopen(/srv/www/htdocs/hingedmind/components/com_sef/cache/shCacheContent.php) [function.fopen]: failed to open stream: Permission denied in /srv/www/htdocs/hingedmind/components/com_sef/shCache.php on line 74


Thanks,
b
Sapient
Fresh Boarder
Fresh Boarder
 
Posts: 4
Joined: Tue Feb 05, 2008 5:59 pm

Re:XML Parsing Error

Postby adams.alex » Fri Feb 15, 2008 8:32 pm

Hi!
I do like you say to me but it's seems that google do not accept this kind of format of XML of you component generates. I have now Xmap 1.1 Beta and google answer to me for every sitemap thios error:
Unsupported file format
Your Sitemap does not appear to be in a supported format. Please ensure it meets our Sitemap guidelines and resubmit.
An example of sitemap generated by my website is:
<div class="1">
<div class="componentheading"/>
?
<div class="contentpaneopen">
<h2 class="menutitle">Meniu</h2>
?
<ul class="level_0">
?
<li>
<a href="http://www.time4music.biz/discografii-discographies/discografii/" title="Discografii (Discographies)">Discografii (Discographies)</a>
?
<ul class="level_1">
?
<li>
<a href="http://www.time4music.biz/discografii-discographies/discografii/0-9/" title="0-9">0-9</a>

Wich is different from 1.0.x xmap component.

Maybe i do something rong in the configuration.

Please help!

The link's for my website xml are:
index.php?option=com_xmap&sitemap=1&view=xml&no_html=1
index.php?option=com_xmap&sitemap=4&view=xml&no_html=1
index.php?option=com_xmap&sitemap=5&view=xml&no_html=1
index.php?option=com_xmap&sitemap=6&view=xml&no_html=1
index.php?option=com_xmap&sitemap=7&view=xml&no_html=1

Thanks
adams.alex
Junior Boarder
Junior Boarder
 
Posts: 23
Joined: Thu Sep 20, 2007 8:27 am

Re:XML Parsing Error

Postby adams.alex » Fri Feb 15, 2008 8:46 pm

Another bug's on Xmap 1.1 beta:
- The component do not save the extern link mark (that gif image).
- Expand Categories and Expand Sections set on "on xml sitemap only", clear all link 's in the xml map.
- There is to many setings, why is need to set the parameters in "Content Plugin 1.0.0" and then do it again in "maps"?
- "Use classic XML Sitemap display" there is no change in the xml generated map in 2 possible cases;
- "Do not include the CSS within the Sitemap" the same, it do not work, i de not see the difference;


Ideeas
- New features proposal: why not to make an multiple sitemap based on section's, categories and items (for content, maximum for each map about 15000 link's, best is if can chose this number) and one map for menu items...for user site map, and possible google.
Last edited by adams.alex on Thu Jan 01, 1970 12:00 am, edited 65535 times in total.
Reason: 1
adams.alex
Junior Boarder
Junior Boarder
 
Posts: 23
Joined: Thu Sep 20, 2007 8:27 am

Re:XML Parsing Error

Postby guilleva » Sat Feb 16, 2008 4:58 pm

Hi Adams, thanks for your feedback. I'll check that asap.

The parameters you set on sitemaps are diferent than the ones you set on the content plugin.

Looks like your sitemap is ok now, maybe was because your sitemap was cached. If you have this problem again, please try cleaning your cache.
User avatar
guilleva
Administrator
Administrator
 
Posts: 1527
Joined: Wed Sep 12, 2007 3:10 am
Location: San José, Costa Rica

Re:XML Parsing Error

Postby adams.alex » Sun Feb 17, 2008 11:54 am

Hi!
My sitemap is ok now because it's generated by 1.0.4 component of Xmap. :)

The 1.1 is not generating the got xml accepted by google. I want to help you on this component, but please use my suggestions for future release.

Thanks
adams.alex
Junior Boarder
Junior Boarder
 
Posts: 23
Joined: Thu Sep 20, 2007 8:27 am


Return to Bugs



Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 7 guests

cron