Tuesday, 23 September 2014 02:21
beggarly

SQL=INSERT INTO jos_xmap_sitemap (not a bug but...)

Report Xmap bugs on this forum.

SQL=INSERT INTO jos_xmap_sitemap (not a bug but...)

Postby xulen » Thu Nov 25, 2010 4:35 am

Hi there, someone can tell me how to address this problem:
Code: Select all
Unknown column 'name' in 'field list' SQL=INSERT INTO jos_xmap_sitemap


it happens as soon as installation finish, and when i try to create the sitemap:
Code: Select all
Unknown column 'name' in 'field list' SQL=INSERT INTO jos_xmap_sitemap (`name`,`expand_category`,`expand_section`,`show_menutitle`,`columns`,`exlinks`,`ext_image`,`menus`,`exclmenus`,`includelink`,`usecache`,`cachelifetime`,`classname`,`count_xml`,`count_html`,`views_xml`,`views_html`,`lastvisit_xml`,`lastvisit_html`,`excluded_items`,`compress_xml`) VALUES ('New Sitemap','1','1','1','1','1','img_grey.gif','mainmenu,0,1,1,0.5,daily','','1','1','360','xmap','0','0','0','0','0','0','','0')


and no sitemap were created. I guess is not a common issue since cant find any reference to it (two exceptions but none relevant).

Thanks
xulen
Fresh Boarder
Fresh Boarder
 
Posts: 1
Joined: Thu Nov 25, 2010 4:25 am

Re: SQL=INSERT INTO --jos_xmap_sitemap (not a bug but...)

Postby archi4shah » Fri Nov 18, 2011 11:52 am

i've same prblm..
i've uninstalled xmap and tried again but the same prblm is found... :(
archi4shah
Fresh Boarder
Fresh Boarder
 
Posts: 1
Joined: Fri Nov 18, 2011 11:47 am

Re: SQL=INSERT INTO jos_xmap_sitemap (not a bug but...)

Postby guilleva » Fri Nov 25, 2011 11:12 pm

Hi, what version of Xmap and Joomla are you using?
User avatar
guilleva
Administrator
Administrator
 
Posts: 1527
Joined: Wed Sep 12, 2007 3:10 am
Location: San José, Costa Rica

Re: SQL=INSERT INTO jos_xmap_sitemap (not a bug but...)

Postby Voblin_UA » Tue Jan 03, 2012 10:36 am

I had the same problem.
Found 2.2 version. Failed to install it on Joomla 1.5 with something like "Can't find Joomla installation XML" error. Searched for the same errors and the ways of solving the problem. Found archives inside the archive - that was a problem. Tried to install com_xmap.zip from the package separately and got a new Menu item COM_XMAP_TITLE and a 404 error clicking on it :)
After uninstalling a new installed component I've got an error of "Unknown column 'name' in 'field list' SQL=INSERT INTO jos_xmap_sitemap ".
I've solved the problem by uninstalling both old Xmap and new Xmap. After that I've reinstalled com_xmap-1.2.14.zip for Joomla! 1.5. Everything is OK. Thank You! :)
Voblin_UA
Fresh Boarder
Fresh Boarder
 
Posts: 2
Joined: Tue Jan 03, 2012 10:26 am

Re: SQL=INSERT INTO jos_xmap_sitemap (not a bug but...)

Postby guilleva » Wed Jan 04, 2012 7:20 am

Hi, Xmap 2 is for Joomla 1.6 or higher, for Joomla 1.5 you should use Xmap 1.2.X instead.
User avatar
guilleva
Administrator
Administrator
 
Posts: 1527
Joined: Wed Sep 12, 2007 3:10 am
Location: San José, Costa Rica

Re: SQL=INSERT INTO jos_xmap_sitemap (not a bug but...)

Postby Voblin_UA » Wed Jan 04, 2012 9:42 am

Thank You! :)
But I've found this component here: http://joomla.vargas.co.cr/en/downloads/components/xmap and I see just
Compatibility with Joomla 1.5 and Joomla 1.6
so I had no doubt about compatibility with my Joomla v.1.5 :) Please add the description about v.2.2 and its availiability only for Joomla v. 1.6 and 1.7 here: http://joomlacode.org/gf/project/xmap/frs/?action=FrsReleaseBrowse&frs_package_id=3882 to avoid future mistakes :)

PS Thank You for the really nice component!
Voblin_UA
Fresh Boarder
Fresh Boarder
 
Posts: 2
Joined: Tue Jan 03, 2012 10:26 am


Return to Bugs



Who is online

Users browsing this forum: Yahoo [Bot] and 3 guests