Saturday, 02 August 2014 00:33
beggarly

Duplicate link in Kunena sitemap

Report Xmap bugs on this forum.

Duplicate link in Kunena sitemap

Postby lucifaro666 » Tue Nov 29, 2011 6:03 pm

There is a bug in Kunena sitemap, links are a duplicate

here is an example:
http://www.hardwaremax.it/index.php?option=com_xmap&view=xml&id=2
lucifaro666
Fresh Boarder
Fresh Boarder
 
Posts: 9
Joined: Mon Sep 26, 2011 8:04 am

Re: Duplicate link in Kunena sitemap

Postby Montimontt » Thu Mar 08, 2012 10:01 am

Hi!

I have the same problem with duplicate links!

Is it possible to fix this bug?? I would be very happy!

My Sitemap: http://www.unterstuetzung-durch-technik.de/sitemap

Thanks!
Montimontt
Fresh Boarder
Fresh Boarder
 
Posts: 4
Joined: Thu Mar 08, 2012 9:55 am

Re: Duplicate link in Kunena sitemap

Postby lucifaro666 » Fri Mar 09, 2012 9:40 am

I'm sorry I removed Kunena
lucifaro666
Fresh Boarder
Fresh Boarder
 
Posts: 9
Joined: Mon Sep 26, 2011 8:04 am

Re: Duplicate link in Kunena sitemap

Postby Montimontt » Fri Mar 09, 2012 10:39 am

No problem. I thought this would be a job for the developers anyway...
Montimontt
Fresh Boarder
Fresh Boarder
 
Posts: 4
Joined: Thu Mar 08, 2012 9:55 am

Re: Duplicate link in Kunena sitemap

Postby stonewalled » Mon Mar 26, 2012 6:16 pm

Just wanted to (hopefully) cast some additional light on this as I believe the developers at Xmap are being unfairly clobbered.

I too have this very same issue:

Joomla 1.7.5, Kunena 1.7.2, Xmap 2.2.1 with the Kunena Plugin 2.0.2

I have found the issue stems from the publication of Categories in the Kunena Menu. Unpublish the categories (tab) menu and the issue goes away. Second, and I think this is more important, the XML file does NOT show the duplication - it does appear that only the HTML output is producing this problem - yes, it looks untidy, but it should not prevent Google from using the XML file correctly and indexing from that file. Any duplicates reported by Google should be able to be deleted as normal or dealt with in your URL management (in my case, SH404SEF)

Like before (and as a SH404SEF user) disable the Joomla SEF in the Global Config, disable the SEF in Kunena, then activate SH404SEF. Xmap does what it always did, but there is additional output from Kunena Categories which Xmap (in good faith) is showing.

I feel sure Xmap will in time provide a work-around and update, but the issue is not a deal breaker.

The issue faced by extension developers such as Xmap has been the change in both operating structure such as Joomla changes and the Kunena changes which have moved along at fast pace. My first reaction was disappointment as a long-time user of Xmap, but realisation that the impact is less than imagined.

My gut feeling is that Xmap will wait until Joomla 2.5+ is on the stable path and Kunena follows along with 1.8+

;)
stonewalled
Fresh Boarder
Fresh Boarder
 
Posts: 2
Joined: Mon Mar 26, 2012 6:02 pm

Re: Duplicate link in Kunena sitemap

Postby stonewalled » Fri Mar 30, 2012 9:49 pm

Kunena has structured its component as a standalone. The introduction of the Kunena Menu is causing this problem. It's throwing a number of issues if Kunena in association with the Joomla Menu is not organised correctly - it makes the best of the worst. Kunena in a Joomla Main Menu is a menu within a menu - duplication.

Xmap is producing the XML correctly. It's the HTML which is causing the problem when Xmap is linked to the Kunena Menu.

[My Solution]

In the Xmap plugin, do not select Kunena Menu when you create the Xmap site map - it will (correctly) produce duplications in the HTML because Kunena is producing multiple paths.

Check out the XML - it's fine. Google is quite happy with it and there are no duplications.

Now all I need is to get the CSS working (yes, I know about class and id - it still doesn't work).

:)
stonewalled
Fresh Boarder
Fresh Boarder
 
Posts: 2
Joined: Mon Mar 26, 2012 6:02 pm

Re: Duplicate link in Kunena sitemap

Postby mikee1978 » Mon Jul 09, 2012 10:39 am

First - sorry for my english.

Second - the same case: J2.5.3, Kunena - 1.7.2, Xmap&kunena plugin - latest. By default xmap duplicates urls (with & without /index) in html sitemap

My solution:
In Kunena menu I made a copy of menu "Contents" (the left one) and disabled the default one (for safety). Next - I set up the type of the copy I made to external url (leads to the forum root). Next - I disabled menu "Latest", cause forum root by default leads to latest. After that it leads to "Contents" by default.

All duplicates in xmap hmtl sitemap vanished. Xml sitemap was clear before and is clear after.
mikee1978
Fresh Boarder
Fresh Boarder
 
Posts: 1
Joined: Mon Jul 09, 2012 10:23 am


Return to Bugs



Who is online

Users browsing this forum: No registered users and 6 guests

cron