Thursday, 23 October 2014 12:28
beggarly

Can't Install Xmap

An open forum for opinions and general questions

Can't Install Xmap

Postby Dom2012 » Fri Jul 27, 2012 9:44 pm

Hi,

I installed it and got some error messages. I checked if it was installed at all and, despite being visible in the Extensions Manager > Manage, I could not find it under Plugins or Components, so I removed it and tried to re-install it.

Now I get this seris or error messages...

Another menu item with the same parent has this alias
Error building Admin Menus
Plugin Install: Another plugin is already using directory: /home/*********/public_html/plugins/xmap/com_content
Package Install: There was an error installing an extension: plg_com_content.zip


What does it mean? How do I fix it? Can anyone help?

Many thanks,
Dom
Dom2012
Fresh Boarder
Fresh Boarder
 
Posts: 1
Joined: Fri Jul 27, 2012 9:41 pm

Re: Can't Install Xmap

Postby LTCreations » Sat Jul 28, 2012 6:30 pm

I have the exact same issue. I originally had a previous version installed. Because I couldn't figure out where all the "bad links" were being generated (I had updated a lot of pages), I uninstalled Xmap and tried to start over. Google was going nuts with all the bad links, but none of the menus I have reflect "any" of the links in the Xmap that are not correct.

I've rebuilt everything and gone through the db. Then I attempted to install the new Xmap. I get the same error as Dom and find the plugins are, in fact, installed. But nothing appears in the "Component " list and there is no way to access anything.

??

I have the previous version installed in another site and it's working fine. Version 2.0 works great in the other site. However, now I can't install the previous version either!!!
After several attempts, each time I get "Fatal error: Call to undefined method JLanguage::getBackwardLang() in ******/public_html/administrator/components/com_xmap/install.xmap.php on line 17"
...when trying to install com_xmap-1.2.14

So please...what's the deal??!!

Thanks.
Tom
LTCreations
Fresh Boarder
Fresh Boarder
 
Posts: 7
Joined: Sat Jul 28, 2012 6:11 pm

Re: Can't Install Xmap

Postby JoomlaCommunity.eu » Mon Aug 13, 2012 11:01 am

I had the same problem re-installing XMAP.
After a long search I found this:
If it is the second time you install XMAP (2.x), You must go to Extension Manager - Manage.
Filter -Select type- Plugin.
Select every XMAP ..... Plugin and Uninstall.

Now you can reinstall XMAP.
User avatar
JoomlaCommunity.eu
Fresh Boarder
Fresh Boarder
 
Posts: 5
Joined: Mon Jan 18, 2010 11:49 am

Re: Can't Install Xmap

Postby lowtech » Tue Aug 21, 2012 8:36 pm

I have the identical problem. I uninstalled and reinstalled twice. Manually checked the DB.
This was an install attempt in a new Joomla 2.5.

Attached are the messages I get.

Any help or suggestions appreciated.



Lowtech
Attachments
xmap install problem1.jpg
In the backend this would indicate something wasn't uninstalled. But everything was that I could find in cPanel and DB.
xmap install problem2.jpg
In the front end, no install appears for the com file
lowtech
Fresh Boarder
Fresh Boarder
 
Posts: 1
Joined: Mon Jul 26, 2010 12:32 pm


Return to General



Who is online

Users browsing this forum: No registered users and 1 guest

cron