Sunday, 20 April 2014 08:17
beggarly

Xmap doesn't work after install: Some SQL issue

Report Xmap bugs on this forum.

Xmap doesn't work after install: Some SQL issue

Postby bozhenko » Fri Aug 24, 2012 2:46 pm

Right after installing Xmap, when I go to Xmap backend, backend gave me this message:

Code: Select all
Unknown column 'a.state' in 'where clause' SQL=SELECT a.*,ag.title AS access_level FROM j25_xmap_sitemap AS a LEFT JOIN j25_viewlevels AS ag ON ag.id = a.access WHERE (a.state = 0 OR a.state = 1) ORDER BY a.title asc Unknown column 'a.state' in 'where clause' SQL=SELECT a.*,ag.title AS access_level FROM j25_xmap_sitemap AS a LEFT JOIN j25_viewlevels AS ag ON ag.id = a.access WHERE (a.state = 0 OR a.state = 1) ORDER BY a.title asc LIMIT 0, 20 Unknown column 'a.state' in 'where clause' SQL=SELECT a.*,ag.title AS access_level FROM j25_xmap_sitemap AS a LEFT JOIN j25_viewlevels AS ag ON ag.id = a.access WHERE (a.state = 0 OR a.state = 1) ORDER BY a.title asc


Could anyone please tell me how can I fix it and make Xmap to work? All the rest of site works fine (at least seems to). Joomla 2.5|K2| Site migrated from 1.5 via JUpgrade.
bozhenko
Fresh Boarder
Fresh Boarder
 
Posts: 2
Joined: Fri Aug 24, 2012 2:38 pm

Re: Xmap doesn't work after install: Some SQL issue

Postby adroussel » Fri Aug 31, 2012 1:57 pm

Same problem here on j2.5.6
adroussel
Fresh Boarder
Fresh Boarder
 
Posts: 4
Joined: Mon Aug 08, 2011 11:03 pm

Re: Xmap doesn't work after install: Some SQL issue

Postby bozhenko » Fri Aug 31, 2012 2:07 pm

adroussel wrote:Same problem here on j2.5.6

I've dealt with this issue. Don't remember where I've read advice to remove xmap totally, clear site's cash and then reinstall it. For me that was a case (imho) because prior to migration I had xmap on old site and it didn't upgrade the right way, so after total remove and installing fresh it works now.
bozhenko
Fresh Boarder
Fresh Boarder
 
Posts: 2
Joined: Fri Aug 24, 2012 2:38 pm

Re: Xmap doesn't work after install: Some SQL issue

Postby adroussel » Fri Aug 31, 2012 2:36 pm

It makes sense. thanks a lot!
adroussel
Fresh Boarder
Fresh Boarder
 
Posts: 4
Joined: Mon Aug 08, 2011 11:03 pm


Return to Bugs



Who is online

Users browsing this forum: No registered users and 1 guest