Saturday, 01 November 2014 05:33
beggarly

Xmap sitemap as sitemap.xml is not working for joomla 2.5

Report Xmap bugs on this forum.

Xmap sitemap as sitemap.xml is not working for joomla 2.5

Postby hmirs » Tue Nov 20, 2012 6:19 pm

I tried the solution described at http://joomla.vargas.co.cr/en/documentation/34-xmap-2/how-to/108-xmap-sitemap-as-sitemapxml and it is working only for joomla 1.5 but not for joomla 2.5.

Please help !
hmirs
Fresh Boarder
Fresh Boarder
 
Posts: 9
Joined: Tue Nov 20, 2012 6:16 pm

Re: Xmap sitemap as sitemap.xml is not working for joomla 2.

Postby guilleva » Tue Nov 20, 2012 7:48 pm

it's working on this site using 2.5 and Xmap 3.0.2:

http://joomla.vargas.co.cr/en/sitemap.xml
http://joomla.vargas.co.cr/es/sitemap.xml

and using this on the .htaccess
Code: Select all
# English sitemap
RewriteCond %{REQUEST_URI} ^/en/sitemap.xml
RewriteRule .* /en/index.php?option=com_xmap&id=1&view=xml
# Spanish sitemap
RewriteCond %{REQUEST_URI} ^/es/sitemap.xml
RewriteRule .* /es/index.php?option=com_xmap&id=2&view=xml
User avatar
guilleva
Administrator
Administrator
 
Posts: 1527
Joined: Wed Sep 12, 2007 3:10 am
Location: San José, Costa Rica

Re: Xmap sitemap as sitemap.xml is not working for joomla 2.

Postby hmirs » Tue Nov 20, 2012 8:06 pm

I received a 500 error
500
View not found [name, type, prefix]: xml, xml, xmapView
hmirs
Fresh Boarder
Fresh Boarder
 
Posts: 9
Joined: Tue Nov 20, 2012 6:16 pm

Re: Xmap sitemap as sitemap.xml is not working for joomla 2.

Postby guilleva » Tue Nov 20, 2012 10:23 pm

And do you receive the same error when you see the sitemap using the non-sef url? the one that starts with index.php?option...
User avatar
guilleva
Administrator
Administrator
 
Posts: 1527
Joined: Wed Sep 12, 2007 3:10 am
Location: San José, Costa Rica

Re: Xmap sitemap as sitemap.xml is not working for joomla 2.

Postby hmirs » Wed Nov 21, 2012 9:17 am

The original link to xmap is working. What is not working is this solution from .htaccess.
http://hmirs.info/sitemap.xml
http://hmirs.info/index.php?option=com_xmap&id=1&view=xml
hmirs
Fresh Boarder
Fresh Boarder
 
Posts: 9
Joined: Tue Nov 20, 2012 6:16 pm

Re: Xmap sitemap as sitemap.xml is not working for joomla 2.

Postby guilleva » Wed Nov 21, 2012 10:46 am

can you post the section of your .htaccess about the sitemap?


BTW, the place we put it in the .htaccess matters, make sure there are not other rules before it that are affecting this rule. Also, please try adding [L] at the end, like this:

Code: Select all
RewriteCond %{REQUEST_URI} ^/sitemap.xml
RewriteRule .* /index.php?option=com_xmap&id=1&view=xml [L]
User avatar
guilleva
Administrator
Administrator
 
Posts: 1527
Joined: Wed Sep 12, 2007 3:10 am
Location: San José, Costa Rica

Re: Xmap sitemap as sitemap.xml is not working for joomla 2.

Postby hmirs » Wed Nov 21, 2012 11:04 am

What do you mean. Do you whant to post all of my .htaccess here ?

I am stuck. I am not a expert in .htaccess and maybe i do something wrong. I try to delete one by one every line from .htaccess but nothing.
hmirs
Fresh Boarder
Fresh Boarder
 
Posts: 9
Joined: Tue Nov 20, 2012 6:16 pm

Re: Xmap sitemap as sitemap.xml is not working for joomla 2.

Postby guilleva » Wed Nov 21, 2012 11:08 am

I didn't mean to post ALL your .htaccess but only the lines related with the xmap (two lines I guess).

Did you try with the lines I suggested you on my previous post?
User avatar
guilleva
Administrator
Administrator
 
Posts: 1527
Joined: Wed Sep 12, 2007 3:10 am
Location: San José, Costa Rica

Re: Xmap sitemap as sitemap.xml is not working for joomla 2.

Postby hmirs » Wed Nov 21, 2012 11:12 am

I put what you suggested ... copy/paste.

I sent to you PM with all my .htaccess.

Thanks again !
hmirs
Fresh Boarder
Fresh Boarder
 
Posts: 9
Joined: Tue Nov 20, 2012 6:16 pm

Re: Xmap sitemap as sitemap.xml is not working for joomla 2.

Postby guilleva » Wed Nov 21, 2012 11:29 am

Hi thanks for sending the .htaccess, please try moving the lines related to Xmap before the line that reads:

Code: Select all
## Begin - Joomla! core SEF Section.
User avatar
guilleva
Administrator
Administrator
 
Posts: 1527
Joined: Wed Sep 12, 2007 3:10 am
Location: San José, Costa Rica

Next

Return to Bugs



Who is online

Users browsing this forum: No registered users and 2 guests