Sábado, 25 Octubre 2014 21:17
beggarly

Backend not working

Report Xmap bugs on this forum.

Backend not working

Postby Forsakensky » Fri Apr 25, 2008 11:55 am

I have Joomla 1.5 with Xmap 1.1

Installation worked fine, but when I click on Components -->Xmap I get the following error

Code: Select all
Warning: main() [function.main]: open_basedir restriction in effect. File(/usr/share/gforge//XmapPlugin.php) is not within the allowed path(s): (/var/www/vhosts/cultuurschok.com/httpdocs:/tmp) in /var/www/vhosts/cultuurschok.com/httpdocs/administrator/components/com_xmap/classes/XmapPluginInstaller.php on line 6

Warning: main(XmapPlugin.php) [function.main]: failed to open stream: Operation not permitted in /var/www/vhosts/cultuurschok.com/httpdocs/administrator/components/com_xmap/classes/XmapPluginInstaller.php on line 6

Fatal error: main() [function.require]: Failed opening required 'XmapPlugin.php' (include_path='.:/usr/share/gforge/:/usr/share/gforge/www/include/') in /var/www/vhosts/cultuurschok.com/httpdocs/administrator/components/com_xmap/classes/XmapPluginInstaller.php on line 6


What do I need to change for Xmap to work?
Forsakensky
Fresh Boarder
Fresh Boarder
 
Posts: 4
Joined: Fri Apr 25, 2008 12:50 pm

Re:Backend not working

Postby Forsakensky » Mon Apr 28, 2008 10:32 am

No one has an answer?

Maybe another topic already discussed this problem, but I can't find it.
Forsakensky
Fresh Boarder
Fresh Boarder
 
Posts: 4
Joined: Fri Apr 25, 2008 12:50 pm

Re:Backend not working

Postby guilleva » Mon Apr 28, 2008 4:13 pm

Hi, edit your file
/administrator/components/com_xmap/classes/XmapPluginInstaller.php

and replace the line:

Code: Select all

require_once('XmapPlugin.php');

by this:
Code: Select all

require_once(JPATH_COMPONENT_ADMINISTRATOR.DS.'classes'.DS.'XmapPlugin.php');
User avatar
guilleva
Administrator
Administrator
 
Posts: 1527
Joined: Wed Sep 12, 2007 3:10 am
Location: San José, Costa Rica

Re:Backend not working

Postby Forsakensky » Mon Apr 28, 2008 5:49 pm

Thanks for you reply.

Found the line in the code, but I couldn't replace it. I got the following error

Error: Unable to edit file /httpdocs/administrator/components/com_xmap/classes/XmapPluginInstaller.php: filemng failed: cp: cannot create regular file `/var/www/vhosts/cultuurschok.com/httpdocs/administrator/components/com_xmap/classes/XmapPluginInstaller.php': Permission denied
filemng: Error occured during /bin/cp command.

What do I need to do now?
Forsakensky
Fresh Boarder
Fresh Boarder
 
Posts: 4
Joined: Fri Apr 25, 2008 12:50 pm

Re:Backend not working

Postby guilleva » Mon Apr 28, 2008 8:13 pm

Maybe you need to edit the file in the package, under the "classes" folder and reinstall the component with this file modified. Please let me know if you need any help!
User avatar
guilleva
Administrator
Administrator
 
Posts: 1527
Joined: Wed Sep 12, 2007 3:10 am
Location: San José, Costa Rica

Re:Backend not working

Postby Forsakensky » Tue Apr 29, 2008 9:36 am

That seemed to do the trick!

Yep..xmap is working

Thank you very much!
Forsakensky
Fresh Boarder
Fresh Boarder
 
Posts: 4
Joined: Fri Apr 25, 2008 12:50 pm


Return to Bugs



Who is online

Users browsing this forum: No registered users and 1 guest