Miércoles, 22 Octubre 2014 04:53
beggarly

JCal Pro plug-in error

Suggest/Comment/Post new extensions for Xmap!

JCal Pro plug-in error

Postby RakiuraSkies » Sat May 23, 2009 2:12 am

Hi
when I run my site-map, the JCal plug-in is reporting:

Warning: Invalid argument supplied for foreach() in ../mysite.com/administrator/components/com_xmap/extensions/com_jcalpro.php on line 67

Warning: Invalid argument supplied for foreach() in ../mysite.com/administrator/components/com_xmap/extensions/com_jcalpro.php on line 90


Has anyone else had the same issue? Is there a fix available? I'm running J! 1.5.10, JCal Pro 2.1.3 (build_217) and XMap 1.2.1

EDIT: I've updated JCal Pro to ver: 2.1.7 (build_277) today, with no improvement in my issue.
RakiuraSkies
Fresh Boarder
Fresh Boarder
 
Posts: 7
Joined: Sat May 23, 2009 2:08 am

Re: JCal Pro plug-in error

Postby RakiuraSkies » Sat May 23, 2009 1:21 pm

anyone, please?
RakiuraSkies
Fresh Boarder
Fresh Boarder
 
Posts: 7
Joined: Sat May 23, 2009 2:08 am

Re: JCal Pro plug-in error

Postby RakiuraSkies » Sun May 24, 2009 5:31 am

It seems from looking at other component plug-ins that the error I am experiencing is fairly common -other components seem to have their own fairly unique fixes to the issue, but none have posted what needs to be changed to resolve the issue. The code as it appears in my com_jcalpro.php at the moment is:

Code: Select all
foreach($rows as $row) {
            if( $row->cat == 0 ) {
            $row->cat = '';

in both locations. I would really appreciate it if someone could point me in the direction I need to be going to sort this please!!!
RakiuraSkies
Fresh Boarder
Fresh Boarder
 
Posts: 7
Joined: Sat May 23, 2009 2:08 am

Re: JCal Pro plug-in error

Postby RakiuraSkies » Tue May 26, 2009 3:30 am

has anyone found anything please? Any advice at all...?
RakiuraSkies
Fresh Boarder
Fresh Boarder
 
Posts: 7
Joined: Sat May 23, 2009 2:08 am

Re: JCal Pro plug-in error

Postby RakiuraSkies » Tue May 26, 2009 3:39 am

Never mind, I have it sorted.

For anyone else that may be experiencing a similar problem, there is another XMAP-JCalPro plugin that works properly available here:

http://www.banitech.com/download/extensions/xmap/234-jcal-pro-v2

Hopefully someone will find this of benefit.
RakiuraSkies
Fresh Boarder
Fresh Boarder
 
Posts: 7
Joined: Sat May 23, 2009 2:08 am

Re: JCal Pro plug-in error

Postby Nina00 » Mon Mar 15, 2010 9:42 am

I tried to install the JcalPro Extension
http://joomla.vargas.co.cr/en/downloads/doc_details/97-jcalpro-extension
but get the following error message:

Warning: require_once(C:\xampp\htdocs\joomla\libraries\joomla\installer\adapters\xmap_ext.php) [function.require-once]: failed to open stream: No such file or directory in C:\xampp\htdocs\joomla\libraries\joomla\installer\installer.php on line 216

Fatal error: require_once() [function.require]: Failed opening required 'C:\xampp\htdocs\joomla\libraries\joomla\installer\adapters\xmap_ext.php' (include_path='.;C:\xampp\php\PEAR') in C:\xampp\htdocs\joomla\libraries\joomla\installer\installer.php on line 216

anybody can help?
Nina00
Fresh Boarder
Fresh Boarder
 
Posts: 1
Joined: Mon Mar 15, 2010 9:26 am

Re: JCal Pro plug-in error

Postby dirtymonkey » Sat May 01, 2010 6:18 pm

RakiuraSkies wrote:Never mind, I have it sorted.

For anyone else that may be experiencing a similar problem, there is another XMAP-JCalPro plugin that works properly available here:

http://www.banitech.com/download/extensions/xmap/234-jcal-pro-v2

Hopefully someone will find this of benefit.


Hi Guillermo, could you get this fixed in next release?

Cheers, Boss. :mrgreen:
User avatar
dirtymonkey
Fresh Boarder
Fresh Boarder
 
Posts: 16
Joined: Fri May 09, 2008 8:57 pm
Location: United Kingdom

Re: JCal Pro plug-in error

Postby dirtymonkey » Sat May 01, 2010 6:20 pm

Nina00 wrote:I tried to install the JcalPro Extension
http://joomla.vargas.co.cr/en/downloads/doc_details/97-jcalpro-extension
but get the following error message:

Warning: require_once(C:\xampp\htdocs\joomla\libraries\joomla\installer\adapters\xmap_ext.php) [function.require-once]: failed to open stream: No such file or directory in C:\xampp\htdocs\joomla\libraries\joomla\installer\installer.php on line 216

Fatal error: require_once() [function.require]: Failed opening required 'C:\xampp\htdocs\joomla\libraries\joomla\installer\adapters\xmap_ext.php' (include_path='.;C:\xampp\php\PEAR') in C:\xampp\htdocs\joomla\libraries\joomla\installer\installer.php on line 216

anybody can help?


Hi Nina00,

I'm guessing you tried installing with Joomla installer and not XMap installer... but you prob worked that out by now. ;)
User avatar
dirtymonkey
Fresh Boarder
Fresh Boarder
 
Posts: 16
Joined: Fri May 09, 2008 8:57 pm
Location: United Kingdom

Re: JCal Pro plug-in error

Postby johnlanglois » Mon Nov 22, 2010 4:17 pm

This thread is a bit dated, but I seem to have the same problem.

Xmap Sitemap reports Warning: Invalid argument supplied for foreach() in /home2/provetlo/public_html/pvl/administrator/components/com_xmap/extensions/com_jcalpro.php on line 68

I have the jcalpro extension set to ignore jcalpro.

Any ideas? Thanks.
johnlanglois
Fresh Boarder
Fresh Boarder
 
Posts: 6
Joined: Fri Dec 18, 2009 6:39 pm


Return to Plugins



Who is online

Users browsing this forum: Bing [Bot] and 4 guests