Jueves, 27 Noviembre 2014 06:38
beggarly

Keywords not seperated by space

zOOm Media Gallery for Joomla 1.5

Keywords not seperated by space

Postby kleurfeest.nl » Tue Jul 14, 2009 9:01 am

Hi All,

fairly new to Zoom I'm very content with the product. However I'm facing one problem with editing keywords for already uploaded files. We are running Joomla 1.5.11 on Ubuntu. Everything works fine but when I try to edit keywords for an image (from the media manager) the spaces between the keywords dissapear. So when I type:
Car, Motorcycle, Holliday <save>
I end up with:
Car,Motorcycle,Holliday
Which is handled as one keyword instead of three.

When uploading pictures from the media manager the spaces are preserved perfectly, no problems there, it's just the editing afterwards. Tried this with IE8 and Firefox 3.0.8.

Update: tried it with several WYSIWYG editors installed, including the "no editor" option but it makes no difference

Anyone any clue?

Thanks,
Ron
kleurfeest.nl
Fresh Boarder
Fresh Boarder
 
Posts: 5
Joined: Tue Jul 14, 2009 8:47 am

Re: Keywords not seperated by space

Postby guilleva » Wed Jul 15, 2009 12:59 pm

Hi, yes, that's an old problem with ZMG, I don't know why they did that but that's how it works, I think I'm going to add a patch for it. In the mean time you can fix it by editing the file /components/com_zoom/lib/image.class.php and removing the following line:
$this->_keywords = ereg_replace(" ", "", $this->_keywords);
User avatar
guilleva
Administrator
Administrator
 
Posts: 1527
Joined: Wed Sep 12, 2007 3:10 am
Location: San José, Costa Rica

Re: Keywords not seperated by space

Postby kleurfeest.nl » Tue Jul 28, 2009 1:04 pm

Thanks!

That worked for me....
kleurfeest.nl
Fresh Boarder
Fresh Boarder
 
Posts: 5
Joined: Tue Jul 14, 2009 8:47 am


Return to zOOm



Who is online

Users browsing this forum: No registered users and 1 guest

cron